{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:synopsys-coverity. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-23848 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:synopsys-coverity to 3.0.3 or later.","what":"CVE-2023-23848 is a medium-severity missing authorization vulnerability in Synopsys Jenkins Coverity Plugin, published on 15 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-23848 and fix it if it is affected.\n\nWhat it is: CVE-2023-23848 is a medium-severity missing authorization vulnerability in Synopsys Jenkins Coverity Plugin, published on 15 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-23848 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:synopsys-coverity (Maven): affected all versions; fixed in 3.0.3\n- org.jenkins-ci.plugins:synopsys-coverity (Maven): affected all versions; fixed in 3.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-23848/ (Markdown: https://insights.sbomify.com/CVE-2023-23848/index.md)","id":"CVE-2023-23848","markdown":"https://insights.sbomify.com/CVE-2023-23848/index.md","name":"CVE-2023-23848","record":{"aliases":["GHSA-c3v2-5388-v8pw"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Coverity Plugin","requires_auth":"low_privilege","summary":"Attackers with read access can steal Jenkins credentials by connecting to a malicious server due to missing permission checks in the Coverity plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"SNPS","cpe":[{"product":"synopsys_coverity","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"},{"id":"CWE-862","name":"Missing Authorization"}],"description":"Missing permission checks in Synopsys Jenkins Coverity Plugin 3.0.2 and earlier allow attackers with Overall/Read permission to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSRF vulnerability in Jenkins Coverity Plugin allow capturing credentials","id":"CVE-2023-23848","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in Coverity","id":"CVE-2023-23849"},"packages":[{"ecosystem":"Maven","fixed":["3.0.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:synopsys-coverity","purl":null,"source":"GHSA-c3v2-5388-v8pw"},{"ecosystem":"Maven","fixed":["3.0.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:synopsys-coverity","purl":"pkg:maven/org.jenkins-ci.plugins/synopsys-coverity","source":"GHSA-c3v2-5388-v8pw"}],"prev":{"headline":"CSRF vulnerability in Synopsys Jenkins Coverity Plugin","id":"CVE-2023-23847"},"products":["Synopsys Jenkins Coverity Plugin"],"published":"2023-02-15","related":[{"cvss_score":4.3,"headline":"Synopsys Jenkins Coverity Plugin has Incorrect Default Permissions","id":"CVE-2023-23850","kev_date_added":null,"published":"2023-02-15"},{"cvss_score":3.5,"headline":"CSRF vulnerability in Synopsys Jenkins Coverity Plugin","id":"CVE-2023-23847","kev_date_added":null,"published":"2023-02-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-18","vendors":["Synopsys"]},"summary":"Attackers with read access can steal Jenkins credentials by connecting to a malicious server due to missing permission checks in the Coverity plugin.","url":"https://insights.sbomify.com/CVE-2023-23848/"}