# CVE-2023-23850: Synopsys Jenkins Coverity Plugin has Incorrect Default Permissions

> Attackers with read access can enumerate stored credential IDs due to missing permission checks in the Jenkins Coverity Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Feb 2023
- **Updated:** 18 Mar 2025
- **Also known as:** GHSA-jwr6-75xh-jh5j

## What is CVE-2023-23850?

CVE-2023-23850 is a medium-severity missing authorization vulnerability in Synopsys Jenkins Coverity Plugin, published on 15 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Synopsys Jenkins Coverity Plugin 3.0.2 and earlier allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.

Weakness: CWE-276 (Incorrect Default Permissions), CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-23850?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:synopsys-coverity. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:synopsys-coverity` | Maven | All versions | 3.0.3 |
| `org.jenkins-ci.plugins:synopsys-coverity` | Maven | All versions | 3.0.3 |

Products: Jenkins Synopsys Coverity.

## How do I fix CVE-2023-23850?

Upgrade org.jenkins-ci.plugins:synopsys-coverity to 3.0.3 or later.

## Is CVE-2023-23850 being exploited?

There is no known exploitation of CVE-2023-23850 in the wild and no public exploit code.

## Other vulnerabilities in Synopsys Jenkins Coverity Plugin

- [CVE-2023-23848](https://insights.sbomify.com/CVE-2023-23848/): CSRF vulnerability in Jenkins Coverity Plugin allow capturing credentials (medium 4.3)
- [CVE-2023-23847](https://insights.sbomify.com/CVE-2023-23847/): CSRF vulnerability in Synopsys Jenkins Coverity Plugin (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23850 and fix it if it is affected.

What it is: CVE-2023-23850 is a medium-severity missing authorization vulnerability in Synopsys Jenkins Coverity Plugin, published on 15 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-23850 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:synopsys-coverity (Maven): affected all versions; fixed in 3.0.3
- org.jenkins-ci.plugins:synopsys-coverity (Maven): affected all versions; fixed in 3.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23850/ (Markdown: https://insights.sbomify.com/CVE-2023-23850/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23850
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23850
- OSV: https://osv.dev/vulnerability/CVE-2023-23850

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23850/
Summaries are generated and may contain mistakes; the official description above is the record.
