CVE-2023-23918 Security feature bypass in Node
Attackers can bypass Node.js experimental permissions to access unauthorized modules, requiring the experimental policy feature to be enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-23918?
CVE-2023-23918 is a high-severity vulnerability in Nodejs Node.js, published on 23 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A privilege escalation vulnerability exists in Node.js <19.6.1, <18.14.1, <16.19.1 and <14.21.3 that made it possible to bypass the experimental Permissions (https://nodejs.org/api/permissions.html) feature in Node.js and access non authorized modules by using process.mainModule.require(). This only affects users who had enabled the experimental permissions option with --experimental-policy.
Weakness: CWE-863
Which versions are affected by CVE-2023-23918?
2 open source packages ship an affected version, including node and node-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
node Bitnami | From 14.0.0 | 14.21.3, 16.19.1, 18.14.1, 19.6.1 |
node-min Bitnami | From 14.0.0 | 14.21.3, 16.19.1, 18.14.1, 19.6.1 |
Products include Nodejs Node.js.
How do I fix CVE-2023-23918?
Upgrade node to a fixed version for your release line: 14.21.3, 16.19.1, 18.14.1 or 19.6.1.
Is CVE-2023-23918 being exploited?
There is no known exploitation of CVE-2023-23918 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Node.js
Sources
Also known as ALPINE-CVE-2023-23918, AZL-13776, BIT-node-2023-23918, BIT-node-min-2023-23918, CLEANSTART-2026-AC75474, CLEANSTART-2026-WO62953 and 2 more.