# CVE-2023-23918: Security feature bypass in Node

> Attackers can bypass Node.js experimental permissions to access unauthorized modules, requiring the experimental policy feature to be enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2023
- **Updated:** 8 May 2025
- **Also known as:** ALPINE-CVE-2023-23918, AZL-13776, BIT-node-2023-23918, BIT-node-min-2023-23918, CLEANSTART-2026-AC75474, CLEANSTART-2026-WO62953, DEBIAN-CVE-2023-23918, GHSA-33p5-m25c-cp6w

## What is CVE-2023-23918?

CVE-2023-23918 is a high-severity vulnerability in Nodejs Node.js, published on 23 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A privilege escalation vulnerability exists in Node.js <19.6.1, <18.14.1, <16.19.1 and <14.21.3 that made it possible to bypass the experimental Permissions (https://nodejs.org/api/permissions.html) feature in Node.js and access non authorized modules by using process.mainModule.require(). This only affects users who had enabled the experimental permissions option with --experimental-policy.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-23918?

2 open source packages ship an affected version, including node and node-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 14.0.0 | 14.21.3, 16.19.1, 18.14.1, 19.6.1 |
| `node-min` | Bitnami | From 14.0.0 | 14.21.3, 16.19.1, 18.14.1, 19.6.1 |

Products: Nodejs Node.js.

## How do I fix CVE-2023-23918?

Upgrade node to a fixed version for your release line: 14.21.3, 16.19.1, 18.14.1 or 19.6.1.

## Is CVE-2023-23918 being exploited?

There is no known exploitation of CVE-2023-23918 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23918 and fix it if it is affected.

What it is: CVE-2023-23918 is a high-severity vulnerability in Nodejs Node.js, published on 23 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-23918 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 14.0.0; fixed in 14.21.3, 16.19.1, 18.14.1, 19.6.1
- node-min (Bitnami): affected from 14.0.0; fixed in 14.21.3, 16.19.1, 18.14.1, 19.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23918/ (Markdown: https://insights.sbomify.com/CVE-2023-23918/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23918
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23918
- OSV: https://osv.dev/vulnerability/CVE-2023-23918

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23918/
Summaries are generated and may contain mistakes; the official description above is the record.
