CVE-2023-23919 Denial of service in Node
Attackers can cause denial of service in Node.js by triggering false positive errors in cryptographic operations due to uncleared OpenSSL error stacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-23919?
CVE-2023-23919 is a high-severity denial of service vulnerability in Nodejs Node.js, published on 23 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A cryptographic vulnerability exists in Node.js <19.2.0, <18.14.1, <16.19.1, <14.21.3 that in some cases did does not clear the OpenSSL error stack after operations that may set it. This may lead to false positive errors during subsequent cryptographic operations that happen to be on the same thread. This in turn could be used to cause a denial of service.
Weakness: CWE-310
Which versions are affected by CVE-2023-23919?
2 open source packages ship an affected version, including node and node-min. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
node Bitnami | From 14.0.0 | 14.21.3, 16.19.1, 18.14.1, 19.2.0 |
node-min Bitnami | From 14.0.0 | 14.21.3, 16.19.1, 18.14.1, 19.2.0 |
Products include Nodejs Node.js.
How do I fix CVE-2023-23919?
Upgrade node to a fixed version for your release line: 14.21.3, 16.19.1, 18.14.1 or 19.2.0.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-23919 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-23919 exists.
Other vulnerabilities in Nodejs Node.js
Sources
Also known as ALPINE-CVE-2023-23919, AZL-13684, BIT-node-2023-23919, BIT-node-min-2023-23919, CLEANSTART-2026-BC88779, CLEANSTART-2026-SS08335 and 2 more.