# CVE-2023-23919: Denial of service in Node

> Attackers can cause denial of service in Node.js by triggering false positive errors in cryptographic operations due to uncleared OpenSSL error stacks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2023
- **Updated:** 30 Apr 2025
- **Also known as:** ALPINE-CVE-2023-23919, AZL-13684, BIT-node-2023-23919, BIT-node-min-2023-23919, CLEANSTART-2026-BC88779, CLEANSTART-2026-SS08335, DEBIAN-CVE-2023-23919, GHSA-mfq6-mjjx-mp7f

## What is CVE-2023-23919?

CVE-2023-23919 is a high-severity denial of service vulnerability in Nodejs Node.js, published on 23 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A cryptographic vulnerability exists in Node.js <19.2.0, <18.14.1, <16.19.1, <14.21.3 that in some cases did does not clear the OpenSSL error stack after operations that may set it. This may lead to false positive errors during subsequent cryptographic operations that happen to be on the same thread. This in turn could be used to cause a denial of service.

Weakness: CWE-310

## Which versions are affected by CVE-2023-23919?

2 open source packages ship an affected version, including node and node-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 14.0.0 | 14.21.3, 16.19.1, 18.14.1, 19.2.0 |
| `node-min` | Bitnami | From 14.0.0 | 14.21.3, 16.19.1, 18.14.1, 19.2.0 |

Products: Nodejs Node.js.

## How do I fix CVE-2023-23919?

Upgrade node to a fixed version for your release line: 14.21.3, 16.19.1, 18.14.1 or 19.2.0.

## Is CVE-2023-23919 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-23919 exists.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23919 and fix it if it is affected.

What it is: CVE-2023-23919 is a high-severity denial of service vulnerability in Nodejs Node.js, published on 23 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-23919 exists.

Affected packages and fixed versions:
- node (Bitnami): affected from 14.0.0; fixed in 14.21.3, 16.19.1, 18.14.1, 19.2.0
- node-min (Bitnami): affected from 14.0.0; fixed in 14.21.3, 16.19.1, 18.14.1, 19.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23919/ (Markdown: https://insights.sbomify.com/CVE-2023-23919/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23919
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23919
- OSV: https://osv.dev/vulnerability/CVE-2023-23919

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23919/
Summaries are generated and may contain mistakes; the official description above is the record.
