CVE-2023-23920 Path traversal in Node
An attacker can load malicious ICU data via untrusted search paths in Node.js, potentially leading to code execution or privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-23920?
CVE-2023-23920 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 23 Feb 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
An untrusted search path vulnerability exists in Node.js. <19.6.1, <18.14.1, <16.19.1, and <14.21.3 that could allow an attacker to search and potentially load ICU data when running with elevated privileges.
Weakness: CWE-426
Which versions are affected by CVE-2023-23920?
2 open source packages ship an affected version, including node and node-min. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
node Bitnami | From 14.0.0 | 14.21.3, 16.19.1, 18.14.1, 19.6.1 |
node-min Bitnami | From 14.0.0 | 14.21.3, 16.19.1, 18.14.1, 19.6.1 |
Linux distribution packages (19)
nodejs10 SUSE:Enterprise Storage 7 | All versions | 10.24.1-150000.1.56.1 |
nodejs12 SUSE:Enterprise Storage 7 | All versions | 12.22.12-150200.4.44.1 |
nodejs12 SUSE:Enterprise Storage 7.1 | All versions | 12.22.12-150200.4.44.1 |
nodejs10 SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 10.24.1-150000.1.56.1 |
nodejs10 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 10.24.1-150000.1.56.1 |
nodejs12 SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 12.22.12-150200.4.44.1 |
nodejs12 SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 12.22.12-150200.4.44.1 |
nodejs12 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 12.22.12-150200.4.44.1 |
nodejs10 SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 10.24.1-150000.1.56.1 |
nodejs10 SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 10.24.1-150000.1.56.1 |
nodejs12 SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 12.22.12-150200.4.44.1 |
nodejs12 SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 12.22.12-150200.4.44.1 |
nodejs10 SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 10.24.1-150000.1.56.1 |
nodejs10 SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 10.24.1-150000.1.56.1 |
nodejs12 SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 12.22.12-150200.4.44.1 |
nodejs12 SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 12.22.12-150200.4.44.1 |
nodejs12 SUSE:Manager Server 4.2 | All versions | 12.22.12-150200.4.44.1 |
nodejs10 openSUSE:Leap 15.4 | All versions | 10.24.1-150000.1.56.1 |
nodejs12 openSUSE:Leap 15.4 | All versions | 12.22.12-150200.4.44.1 |
Products include Debian Debian Linux, Nodejs Node.js.
How do I fix CVE-2023-23920?
Upgrade node to a fixed version for your release line: 14.21.3, 16.19.1, 18.14.1 or 19.6.1.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2023-23920 being exploited?
There is no known exploitation of CVE-2023-23920 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2023-23920, BIT-node-2023-23920, BIT-node-min-2023-23920, CLEANSTART-2026-FM96299, CLEANSTART-2026-SB43839, DEBIAN-CVE-2023-23920 and 5 more.