CVE-2023-23922 Moodle: reflected xss risk in blog search
Remote attackers can execute arbitrary scripts in victims' browsers via crafted links in Moodle blog search, potentially leading to session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-23922?
CVE-2023-23922 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 17 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The vulnerability was found Moodle which exists due to insufficient sanitization of user-supplied data in blog search. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website. This flaw allows a remote attacker to perform cross-site scripting (XSS) attacks.
Weakness: CWE-79
Which versions are affected by CVE-2023-23922?
5 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 4.0.0-beta | 4.0.6 |
moodle/moodle Packagist | From 4.0.0-beta | 4.0.6 |
moodle/moodle Packagist | From 4.1.0-beta | 4.1.1 |
moodle/moodle Packagist | From 4.1.0-beta | 4.1.1 |
moodle Bitnami | From 4.0.0 | 4.0.6, 4.1.1 |
Products include Moodle Moodle.
How do I fix CVE-2023-23922?
Upgrade moodle/moodle to a fixed version for your release line: 4.0.6 or 4.1.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-23922 being exploited?
There is no known exploitation of CVE-2023-23922 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2023-23922, GHSA-grmj-gpwm-98ww, UBUNTU-CVE-2023-23922.