CVE-2023-23923 Moodle: possible to set the preferred "start page" of other users
Remote attackers can modify other users' start page preferences, gaining unauthorized access to restricted functionality in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-23923?
CVE-2023-23923 is a high-severity missing authorization vulnerability in Moodle Moodle, published on 17 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The vulnerability was found Moodle which exists due to insufficient limitations on the "start page" preference. A remote attacker can set that preference for another user. The vulnerability allows a remote attacker to gain unauthorized access to otherwise restricted functionality.
Weakness: CWE-284
Which versions are affected by CVE-2023-23923?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.9.19 |
moodle/moodle Packagist | All versions | 3.9.19 |
moodle/moodle Packagist | From 3.10.0 | 3.11.12 |
moodle/moodle Packagist | From 3.10.0 | 3.11.12 |
moodle/moodle Packagist | From 4.0.0-beta | 4.0.6 |
moodle/moodle Packagist | From 4.0.0-beta | 4.0.6 |
3 more packages
moodle/moodle Packagist | From 4.1.0-beta | 4.1.1 |
moodle/moodle Packagist | From 4.1.0-beta | 4.1.1 |
moodle Bitnami | From 3.9.0 | 3.9.19, 3.11.12, 4.0.6, 4.1.1 |
Products include Moodle Moodle.
How do I fix CVE-2023-23923?
Upgrade moodle/moodle to a fixed version for your release line: 3.9.19, 3.11.12, 4.0.6 or 4.1.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-23923 being exploited?
There is no known exploitation of CVE-2023-23923 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2023-23923, GHSA-32jc-9p58-p82x, UBUNTU-CVE-2023-23923.