# CVE-2023-23923: Moodle: possible to set the preferred "start page" of other users

> Remote attackers can modify other users' start page preferences, gaining unauthorized access to restricted functionality in Moodle.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Feb 2023
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-moodle-2023-23923, GHSA-32jc-9p58-p82x, UBUNTU-CVE-2023-23923

## What is CVE-2023-23923?

CVE-2023-23923 is a high-severity missing authorization vulnerability in Moodle Moodle, published on 17 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The vulnerability was found Moodle which exists due to insufficient limitations on the "start page" preference. A remote attacker can set that preference for another user. The vulnerability allows a remote attacker to gain unauthorized access to otherwise restricted functionality.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-23923?

9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 3.9.19 |
| `moodle/moodle` | Packagist | All versions | 3.9.19 |
| `moodle/moodle` | Packagist | From 3.10.0 | 3.11.12 |
| `moodle/moodle` | Packagist | From 3.10.0 | 3.11.12 |
| `moodle/moodle` | Packagist | From 4.0.0-beta | 4.0.6 |
| `moodle/moodle` | Packagist | From 4.0.0-beta | 4.0.6 |
| `moodle/moodle` | Packagist | From 4.1.0-beta | 4.1.1 |
| `moodle/moodle` | Packagist | From 4.1.0-beta | 4.1.1 |
| `moodle` | Bitnami | From 3.9.0 | 3.9.19, 3.11.12, 4.0.6, 4.1.1 |

Products: Moodle Moodle.

## How do I fix CVE-2023-23923?

Upgrade moodle/moodle to a fixed version for your release line: 3.9.19, 3.11.12, 4.0.6 or 4.1.1.

## Is CVE-2023-23923 being exploited?

There is no known exploitation of CVE-2023-23923 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23923 and fix it if it is affected.

What it is: CVE-2023-23923 is a high-severity missing authorization vulnerability in Moodle Moodle, published on 17 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-23923 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 3.9.19
- moodle/moodle (Packagist): affected all versions; fixed in 3.9.19
- moodle/moodle (Packagist): affected from 3.10.0; fixed in 3.11.12
- moodle/moodle (Packagist): affected from 3.10.0; fixed in 3.11.12
- moodle/moodle (Packagist): affected from 4.0.0-beta; fixed in 4.0.6
- moodle/moodle (Packagist): affected from 4.0.0-beta; fixed in 4.0.6
- moodle/moodle (Packagist): affected from 4.1.0-beta; fixed in 4.1.1
- moodle/moodle (Packagist): affected from 4.1.0-beta; fixed in 4.1.1
- moodle (Bitnami): affected from 3.9.0; fixed in 3.9.19, 3.11.12, 4.0.6, 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23923/ (Markdown: https://insights.sbomify.com/CVE-2023-23923/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23923
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23923
- OSV: https://osv.dev/vulnerability/CVE-2023-23923

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23923/
Summaries are generated and may contain mistakes; the official description above is the record.
