# CVE-2023-23925: Switcher Client contains Regular Expression Denial of Service (ReDoS)

> An attacker can cause a denial of service in the Switcher Client SDK by exploiting a Regular Expression Denial of Service vulnerability in strategy matching.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-wqxw-8h5g-hq56

## What is CVE-2023-23925?

CVE-2023-23925 is a high-severity denial of service vulnerability in switcherapi switcher-client-master, published on 3 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Switcher Client is a JavaScript SDK to work with Switcher API which is cloud-based Feature Flag. Unsanitized input flows into Strategy match operation (EXIST), where it is used to build a regular expression. This may result in a Regular expression Denial of Service attack (reDOS). This issue has been patched in version 3.1.4. As a workaround, avoid using Strategy settings that use REGEX in conjunction with EXIST and NOT_EXIST operations.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2023-23925?

2 open source packages ship an affected version, including switcher-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `switcher-client` | npm | All versions | 3.1.4 |
| `switcher-client` | npm | All versions | 3.1.4 |

Products: Switcherapi Switcher Client.

## How do I fix CVE-2023-23925?

Upgrade switcher-client to 3.1.4 or later.

## Is CVE-2023-23925 being exploited?

There is no known exploitation of CVE-2023-23925 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23925 and fix it if it is affected.

What it is: CVE-2023-23925 is a high-severity denial of service vulnerability in switcherapi switcher-client-master, published on 3 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-23925 in the wild and no public exploit code.

Affected packages and fixed versions:
- switcher-client (npm): affected all versions; fixed in 3.1.4
- switcher-client (npm): affected all versions; fixed in 3.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23925/ (Markdown: https://insights.sbomify.com/CVE-2023-23925/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23925
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23925
- OSV: https://osv.dev/vulnerability/CVE-2023-23925

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23925/
Summaries are generated and may contain mistakes; the official description above is the record.
