{"answers":{"affected":"3 open source packages ship an affected version, including vantage6. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-23930 in the wild and no public exploit code.","fix":"Upgrade vantage6 to 4.0.2 or later.","what":"CVE-2023-23930 is a medium-severity unsafe deserialization vulnerability in vantage6, published on 11 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-23930 and fix it if it is affected.\n\nWhat it is: CVE-2023-23930 is a medium-severity unsafe deserialization vulnerability in vantage6, published on 11 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-23930 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vantage6 (PyPI): affected all versions; fixed in 4.0.2\n- vantage6 (PyPI): affected all versions; fixed in 4.0.2\n- vantage6 (PyPI): affected all versions; fixed in 4.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-23930/ (Markdown: https://insights.sbomify.com/CVE-2023-23930/index.md)","id":"CVE-2023-23930","markdown":"https://insights.sbomify.com/CVE-2023-23930/index.md","name":"CVE-2023-23930","record":{"aliases":["GHSA-5m22-cfq9-86x6","PYSEC-2023-196"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Federated learning infrastructure","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary code by exploiting insecure pickle deserialization in vantage6 task submissions.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vantage6","vendor":"vantage6"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"vantage6 is privacy preserving federated learning infrastructure. Versions prior to 4.0.0 use pickle, which has known security issue, as a default serialization module but that has known security issues. All users of vantage6 that post tasks with the default serialization are affected. Version 4.0.0 contains a patch. Users may specify JSON serialization as a workaround.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vantage6's Pickle serialization is insecure","id":"CVE-2023-23930","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2023"},"n_packages":3,"n_references":4,"next":{"headline":"Cipher.update_into can corrupt memory in pyca cryptography","id":"CVE-2023-23931"},"packages":[{"ecosystem":"PyPI","fixed":["4.0.2"],"introduced":["0"],"last_affected":[],"package":"vantage6","purl":null,"source":"GHSA-5m22-cfq9-86x6"},{"ecosystem":"PyPI","fixed":["4.0.2"],"introduced":["0"],"last_affected":[],"package":"vantage6","purl":"pkg:pypi/vantage6","source":"GHSA-5m22-cfq9-86x6"},{"ecosystem":"PyPI","fixed":["4.0.2"],"introduced":["0"],"last_affected":[],"package":"vantage6","purl":"pkg:pypi/vantage6","source":"PYSEC-2023-196"}],"prev":{"headline":"Refresh tokens do not expire in Vantage6","id":"CVE-2023-23929"},"products":["vantage6"],"published":"2023-10-11","related":[{"cvss_score":8.8,"headline":"Remote code execution","id":"CVE-2024-21649","kev_date_added":null,"published":"2024-01-30"},{"cvss_score":8.8,"headline":"Refresh tokens do not expire in Vantage6","id":"CVE-2023-23929","kev_date_added":null,"published":"2023-03-03"},{"cvss_score":7.2,"headline":"vantage6 Node accepts non-whitelisted algorithms from malicious server","id":"CVE-2023-47631","kev_date_added":null,"published":"2023-11-14"},{"cvss_score":6.5,"headline":"vantage6 insecure SSH configuration for node and server containers","id":"CVE-2024-21653","kev_date_added":null,"published":"2024-01-30"},{"cvss_score":6.3,"headline":"Improper Preservation of Permissions in vantage6","id":"CVE-2023-22738","kev_date_added":null,"published":"2023-03-01"},{"cvss_score":5.4,"headline":"Defining resource name as integer in vantage6 may give unintended access","id":"CVE-2023-28635","kev_date_added":null,"published":"2023-10-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-18","vendors":["vantage6"]},"summary":"Attackers can execute arbitrary code by exploiting insecure pickle deserialization in vantage6 task submissions.","url":"https://insights.sbomify.com/CVE-2023-23930/"}