# CVE-2023-23930: vantage6's Pickle serialization is insecure

> Attackers can execute arbitrary code by exploiting insecure pickle deserialization in vantage6 task submissions.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Oct 2023
- **Updated:** 18 Sep 2024
- **Also known as:** GHSA-5m22-cfq9-86x6, PYSEC-2023-196

## What is CVE-2023-23930?

CVE-2023-23930 is a medium-severity unsafe deserialization vulnerability in vantage6, published on 11 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

vantage6 is privacy preserving federated learning infrastructure. Versions prior to 4.0.0 use pickle, which has known security issue, as a default serialization module but that has known security issues. All users of vantage6 that post tasks with the default serialization are affected. Version 4.0.0 contains a patch. Users may specify JSON serialization as a workaround.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-23930?

3 open source packages ship an affected version, including vantage6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6` | PyPI | All versions | 4.0.2 |
| `vantage6` | PyPI | All versions | 4.0.2 |
| `vantage6` | PyPI | All versions | 4.0.2 |

Products: Vantage6 Vantage6.

## How do I fix CVE-2023-23930?

Upgrade vantage6 to 4.0.2 or later.

## Is CVE-2023-23930 being exploited?

There is no known exploitation of CVE-2023-23930 in the wild and no public exploit code.

## Other vulnerabilities in vantage6

- [CVE-2024-21649](https://insights.sbomify.com/CVE-2024-21649/): Remote code execution (high 8.8)
- [CVE-2023-23929](https://insights.sbomify.com/CVE-2023-23929/): Refresh tokens do not expire in Vantage6 (high 8.8)
- [CVE-2023-47631](https://insights.sbomify.com/CVE-2023-47631/): vantage6 Node accepts non-whitelisted algorithms from malicious server (high 7.2)
- [CVE-2024-21653](https://insights.sbomify.com/CVE-2024-21653/): vantage6 insecure SSH configuration for node and server containers (medium 6.5)
- [CVE-2023-22738](https://insights.sbomify.com/CVE-2023-22738/): Improper Preservation of Permissions in vantage6 (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23930 and fix it if it is affected.

What it is: CVE-2023-23930 is a medium-severity unsafe deserialization vulnerability in vantage6, published on 11 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-23930 in the wild and no public exploit code.

Affected packages and fixed versions:
- vantage6 (PyPI): affected all versions; fixed in 4.0.2
- vantage6 (PyPI): affected all versions; fixed in 4.0.2
- vantage6 (PyPI): affected all versions; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23930/ (Markdown: https://insights.sbomify.com/CVE-2023-23930/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23930
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23930
- OSV: https://osv.dev/vulnerability/CVE-2023-23930

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23930/
Summaries are generated and may contain mistakes; the official description above is the record.
