# CVE-2023-23936: CRLF Injection in Nodejs ‘undici’ via host

> Attackers can inject CRLF characters into the host header, potentially causing HTTP request smuggling or response splitting in applications using the undici library.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** ALPINE-CVE-2023-23936, AZL-13604, BIT-node-2023-23936, BIT-node-min-2023-23936, CLEANSTART-2026-AU79702, CLEANSTART-2026-BN25034, DEBIAN-CVE-2023-23936, GHSA-5r9g-qh6m-jxff

## What is CVE-2023-23936?

CVE-2023-23936 is a medium-severity vulnerability in Nodejs Node.js, published on 16 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Undici is an HTTP/1.1 client for Node.js. Starting with version 2.0.0 and prior to version 5.19.1, the undici library does not protect `host` HTTP header from CRLF injection vulnerabilities. This issue is patched in Undici v5.19.1. As a workaround, sanitize the `headers.host` string before passing to undici.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2023-23936?

4 open source packages ship an affected version, including undici, node and node-min. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 2.0.0 | 5.19.1 |
| `undici` | npm | From 2.0.0 | 5.19.1 |
| `node` | Bitnami | From 16.0.0 | 16.19.1, 18.14.1, 19.6.1 |
| `node-min` | Bitnami | From 16.0.0 | 16.19.1, 18.14.1, 19.6.1 |

Products: Nodejs Node.js, Nodejs Undici.

## How do I fix CVE-2023-23936?

Upgrade undici to 5.19.1 or later.

## Is CVE-2023-23936 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-23936 exists.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23936 and fix it if it is affected.

What it is: CVE-2023-23936 is a medium-severity vulnerability in Nodejs Node.js, published on 16 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-23936 exists.

Affected packages and fixed versions:
- undici (npm): affected from 2.0.0; fixed in 5.19.1
- undici (npm): affected from 2.0.0; fixed in 5.19.1
- node (Bitnami): affected from 16.0.0; fixed in 16.19.1, 18.14.1, 19.6.1
- node-min (Bitnami): affected from 16.0.0; fixed in 16.19.1, 18.14.1, 19.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23936/ (Markdown: https://insights.sbomify.com/CVE-2023-23936/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23936
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23936
- OSV: https://osv.dev/vulnerability/CVE-2023-23936

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23936/
Summaries are generated and may contain mistakes; the official description above is the record.
