# CVE-2023-23940: OpenZeppelin Contracts for Cairo is vulnerable to signature validation bypass


- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 3 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-626q-v9j4-mcp4, PYSEC-2023-39

## What is CVE-2023-23940?

CVE-2023-23940 is a medium-severity vulnerability in OpenZeppelin cairo-contracts, published on 3 Feb 2023. 

### Official description

OpenZeppelin Contracts for Cairo is a library for secure smart contract development written in Cairo for StarkNet, a decentralized ZK Rollup. `is_valid_eth_signature` is missing a call to `finalize_keccak` after calling `verify_eth_signature`. As a result, any contract using `is_valid_eth_signature` from the account library (such as the `EthAccount` preset) is vulnerable to a malicious sequencer. Specifically, the malicious sequencer would be able to bypass signature validation to impersonate an instance of these accounts. The issue has been patched in 0.6.1.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2023-23940?

3 open source packages ship an affected version, including openzeppelin-cairo-contracts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openzeppelin-cairo-contracts` | PyPI | From 0.2.0 | 0.6.1 |
| `openzeppelin-cairo-contracts` | PyPI | From 0.2.0 | 0.6.1 |
| `openzeppelin-cairo-contracts` | PyPI | From 0.2.0 | 0.6.1 |

Products: Openzeppelin Contracts.

## How do I fix CVE-2023-23940?

Upgrade openzeppelin-cairo-contracts to 0.6.1 or later.

## Is CVE-2023-23940 being exploited?

There is no known exploitation of CVE-2023-23940 in the wild and no public exploit code.

## Other vulnerabilities in OpenZeppelin cairo-contracts

- [CVE-2021-39167](https://insights.sbomify.com/CVE-2021-39167/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-39168](https://insights.sbomify.com/CVE-2021-39168/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-41264](https://insights.sbomify.com/CVE-2021-41264/): UUPSUpgradeable vulnerability in OpenZeppelin Contracts (critical 9.8)
- [CVE-2022-35961](https://insights.sbomify.com/CVE-2022-35961/): ECDSA signature malleability in OpenZeppelin Contracts (high 7.9)
- [CVE-2022-31198](https://insights.sbomify.com/CVE-2022-31198/): GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23940 and fix it if it is affected.

What it is: CVE-2023-23940 is a medium-severity vulnerability in OpenZeppelin cairo-contracts, published on 3 Feb 2023. 
Exploitation: There is no known exploitation of CVE-2023-23940 in the wild and no public exploit code.

Affected packages and fixed versions:
- openzeppelin-cairo-contracts (PyPI): affected from 0.2.0; fixed in 0.6.1
- openzeppelin-cairo-contracts (PyPI): affected from 0.2.0; fixed in 0.6.1
- openzeppelin-cairo-contracts (PyPI): affected from 0.2.0; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23940/ (Markdown: https://insights.sbomify.com/CVE-2023-23940/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23940
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23940
- OSV: https://osv.dev/vulnerability/CVE-2023-23940

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23940/
Summaries are generated and may contain mistakes; the official description above is the record.
