CVE-2023-23969 Django contains Uncontrolled Resource Consumption via cached header
Attackers can cause denial of service by sending large Accept-Language headers, exhausting server memory in Django applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-23969?
CVE-2023-23969 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 1 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Django 3.2 before 3.2.17, 4.0 before 4.0.9, and 4.1 before 4.1.6, the parsed values of Accept-Language headers are cached in order to avoid repetitive parsing. This leads to a potential denial-of-service vector via excessive memory usage if the raw value of Accept-Language headers is very large.
Weakness: CWE-770
Which versions are affected by CVE-2023-23969?
8 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 3.2.0 | 3.2.17, 4.0.9, 4.1.6 |
django PyPI | From 3.2 | 3.2.17, 4.0.9, 4.1.6 |
django PyPI | From 3.2a1 | 3.2.17 |
django PyPI | From 4.0a1 | 4.0.9 |
django PyPI | From 4.1a1 | 4.1.6 |
Django PyPI | From 3.2a1 | 3.2.17 |
2 more packages
Django PyPI | From 4.0a1 | 4.0.9 |
Django PyPI | From 4.1a1 | 4.1.6 |
Linux distribution packages (1)
python-Django openSUSE:Tumbleweed | All versions | 4.1.6-1.1 |
Products include Debian Debian Linux, Djangoproject Django.
How do I fix CVE-2023-23969?
Upgrade django to a fixed version for your release line: 3.2.17, 4.0.9 or 4.1.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-23969 being exploited?
There is no known exploitation of CVE-2023-23969 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-django-2023-23969, DEBIAN-CVE-2023-23969, DLA-3306-1, GHSA-q2jf-h9jm-m7p4, OESA-2023-1097, OESA-2023-1098 and 7 more.