# CVE-2023-2422: Keycloak: oauth client impersonation

> Attackers with valid certificates can impersonate other OAuth clients in mTLS-enabled Keycloak servers, accessing unauthorized data.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Oct 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-3qh5-qqj2-c78f

## What is CVE-2023-2422?

CVE-2023-2422 is a medium-severity authentication bypass vulnerability in Redhat Keycloak, published on 4 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A flaw was found in Keycloak. A Keycloak server configured to support mTLS authentication for OAuth/OpenID clients does not properly verify the client certificate chain. A client that possesses a proper certificate can authorize itself as any other client, therefore, access data that belongs to other clients.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2023-2422?

2 open source packages ship an affected version, including org.keycloak:keycloak-services. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 21.1.2 |
| `org.keycloak:keycloak-services` | Maven | All versions | 21.1.2 |

Products: Redhat Keycloak, Redhat Openshift Container Platform, Redhat Single Sign-On.

## How do I fix CVE-2023-2422?

Upgrade org.keycloak:keycloak-services to 21.1.2 or later.

## Is CVE-2023-2422 being exploited?

There is no known exploitation of CVE-2023-2422 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2422 and fix it if it is affected.

What it is: CVE-2023-2422 is a medium-severity authentication bypass vulnerability in Redhat Keycloak, published on 4 Oct 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-2422 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 21.1.2
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 21.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2422/ (Markdown: https://insights.sbomify.com/CVE-2023-2422/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2422
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2422
- OSV: https://osv.dev/vulnerability/CVE-2023-2422

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2422/
Summaries are generated and may contain mistakes; the official description above is the record.
