# CVE-2023-24230: Formwork Cross-site Scripting (XSS) from Page title field

> Attackers can execute arbitrary scripts via stored XSS in the Page title parameter of the Formwork dashboard.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Feb 2023
- **Updated:** 24 Mar 2025
- **Also known as:** GHSA-fvrh-wrpf-6q7h

## What is CVE-2023-24230?

CVE-2023-24230 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Feb 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A stored cross-site scripting (XSS) vulnerability in the component /formwork/panel/dashboard of Formwork v1.12.1 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the Page title parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-24230?

2 open source packages ship an affected version, including getformwork/formwork. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getformwork/formwork` | Packagist | All versions | 1.13.0 |
| `getformwork/formwork` | Packagist | All versions | 1.13.0 |

Products: Formwork Project Formwork.

## How do I fix CVE-2023-24230?

Upgrade getformwork/formwork to 1.13.0 or later.

## Is CVE-2023-24230 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-24230 exists.

## Other vulnerabilities in n/a

- [CVE-2026-27198](https://insights.sbomify.com/CVE-2026-27198/): Formwork Improperly Manages Privileges During User Creation (high 8.8)
- [CVE-2025-65956](https://insights.sbomify.com/CVE-2025-65956/): Formwork CMS Has a Stored Cross-Site Scripting (XSS) Vulnerability in Blog Tags (medium 6.5)
- [CVE-2024-37160](https://insights.sbomify.com/CVE-2024-37160/): Formwork has a Cross-site scripting (XSS) vulnerability in Description metadata (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-24230 and fix it if it is affected.

What it is: CVE-2023-24230 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Feb 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-24230 exists.

Affected packages and fixed versions:
- getformwork/formwork (Packagist): affected all versions; fixed in 1.13.0
- getformwork/formwork (Packagist): affected all versions; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-24230/ (Markdown: https://insights.sbomify.com/CVE-2023-24230/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-24230
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-24230
- OSV: https://osv.dev/vulnerability/CVE-2023-24230

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-24230/
Summaries are generated and may contain mistakes; the official description above is the record.
