CVE-2023-2442 Cross-site scripting in GitLab

High 8.7 Published Updated

Attackers can execute arbitrary scripts in victims' browsers via crafted merge requests, potentially taking over accounts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-2442?

CVE-2023-2442 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 7 Jun 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.11 before 15.11.7, all versions starting from 16.0 before 16.0.2. A specially crafted merge request could lead to a stored XSS on the client side which allows attackers to perform arbitrary actions on behalf of victims.

Weakness: CWE-79

Which versions are affected by CVE-2023-2442?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.11.015.11.7, 16.0.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-2442?

Upgrade gitlab to a fixed version for your release line: 15.11.7 or 16.0.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-2442 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2442 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-2442, GHSA-8f3h-5jcr-r8cm, UBUNTU-CVE-2023-2442.

Is CVE-2023-2442 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free