{"answers":{"affected":"2 open source packages ship an affected version, including com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-24423 in the wild and no public exploit code.","fix":"Upgrade com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger to 2.38.1 or later.","what":"CVE-2023-24423 is a medium-severity vulnerability in Jenkins Gerrit Trigger Plugin, published on 24 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-24423 and fix it if it is affected.\n\nWhat it is: CVE-2023-24423 is a medium-severity vulnerability in Jenkins Gerrit Trigger Plugin, published on 24 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-24423 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven): affected all versions; fixed in 2.38.1\n- com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger (Maven): affected all versions; fixed in 2.38.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-24423/ (Markdown: https://insights.sbomify.com/CVE-2023-24423/index.md)","id":"CVE-2023-24423","markdown":"https://insights.sbomify.com/CVE-2023-24423/index.md","name":"CVE-2023-24423","record":{"aliases":["GHSA-95jq-24cr-pgrq"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Gerrit Plugin","requires_auth":"none","summary":"Attackers can force Jenkins to rebuild previous Gerrit-triggered builds via CSRF, requiring plugin updates.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"gerrit_trigger","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery (CSRF) vulnerability in Jenkins Gerrit Trigger Plugin 2.38.0 and earlier allows attackers to rebuild previous builds triggered by Gerrit.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site request forgery in Jenkins Gerrit Trigger Plugin","id":"CVE-2023-24423","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Session fixation vulnerability in Jenkins OpenId Connect Authentication Plugin","id":"CVE-2023-24424"},"packages":[{"ecosystem":"Maven","fixed":["2.38.1"],"introduced":["0"],"last_affected":[],"package":"com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger","purl":null,"source":"GHSA-95jq-24cr-pgrq"},{"ecosystem":"Maven","fixed":["2.38.1"],"introduced":["0"],"last_affected":[],"package":"com.sonyericsson.hudson.plugins.gerrit:gerrit-trigger","purl":"pkg:maven/com.sonyericsson.hudson.plugins.gerrit/gerrit-trigger","source":"GHSA-95jq-24cr-pgrq"}],"prev":{"headline":"Sandbox bypass in Jenkins Script Security Plugin","id":"CVE-2023-24422"},"products":["Jenkins Gerrit Trigger Plugin"],"published":"2023-01-24","related":[{"cvss_score":8.8,"headline":"Cross-Site Request Forgery in Jenkins Gerrit Trigger Plugin","id":"CVE-2019-16551","kev_date_added":null,"published":"2019-12-17"},{"cvss_score":5.4,"headline":"Stored Cross-site Scripting vulnerability in Jenkins Gerrit Trigger Plugin","id":"CVE-2022-29039","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":5.4,"headline":"Missing permission check in Jenkins Gerrit Trigger Plugin","id":"CVE-2019-16552","kev_date_added":null,"published":"2019-12-17"},{"cvss_score":5.4,"headline":"Incorrect Authorization in Jenkins Gerrit Trigger Plugin","id":"CVE-2018-1000106","kev_date_added":null,"published":"2018-03-13"},{"cvss_score":4.3,"headline":"Incorrect Authorization in Jenkins Gerrit Trigger Plugin","id":"CVE-2018-1000105","kev_date_added":null,"published":"2018-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-02","vendors":["Jenkins Project"]},"summary":"Attackers can force Jenkins to rebuild previous Gerrit-triggered builds via CSRF, requiring plugin updates.","url":"https://insights.sbomify.com/CVE-2023-24423/"}