{"answers":{"affected":"2 open source packages ship an affected version, including com.cloudbees.jenkins.plugins:kubernetes-credentials-provider. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-24425 in the wild and no public exploit code.","fix":"Upgrade com.cloudbees.jenkins.plugins:kubernetes-credentials-provider to 1.209.v862c6e5fb or later.","what":"CVE-2023-24425 is a medium-severity missing authorization vulnerability in Jenkins Kubernetes Credentials Provider Plugin, published on 24 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-24425 and fix it if it is affected.\n\nWhat it is: CVE-2023-24425 is a medium-severity missing authorization vulnerability in Jenkins Kubernetes Credentials Provider Plugin, published on 24 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-24425 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.cloudbees.jenkins.plugins:kubernetes-credentials-provider (Maven): affected all versions; fixed in 1.209.v862c6e5fb\n- com.cloudbees.jenkins.plugins:kubernetes-credentials-provider (Maven): affected all versions; fixed in 1.209.v862c6e5fb\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-24425/ (Markdown: https://insights.sbomify.com/CVE-2023-24425/index.md)","id":"CVE-2023-24425","markdown":"https://insights.sbomify.com/CVE-2023-24425/index.md","name":"CVE-2023-24425","record":{"aliases":["GHSA-2jpx-h8j2-g8m4"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Kubernetes plugin","requires_auth":"low_privilege","summary":"Attackers with Item/Configure permission can access unauthorized Kubernetes credentials due to missing context in credential lookup.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"kubernetes_credentials_provider","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"Jenkins Kubernetes Credentials Provider Plugin 1.208.v128ee9800c04 and earlier does not set the appropriate context for Kubernetes credentials lookup, allowing attackers with Item/Configure permission to access and potentially capture Kubernetes credentials they are not entitled to.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of system-scoped Kubernetes credentials in Jenkins Kubernetes Credentials Provider Plugin","id":"CVE-2023-24425","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Insufficient Session Expiration in Jenkins Azure AD Plugin","id":"CVE-2023-24426"},"packages":[{"ecosystem":"Maven","fixed":["1.209.v862c6e5fb"],"introduced":["0"],"last_affected":[],"package":"com.cloudbees.jenkins.plugins:kubernetes-credentials-provider","purl":null,"source":"GHSA-2jpx-h8j2-g8m4"},{"ecosystem":"Maven","fixed":["1.209.v862c6e5fb"],"introduced":["0"],"last_affected":[],"package":"com.cloudbees.jenkins.plugins:kubernetes-credentials-provider","purl":"pkg:maven/com.cloudbees.jenkins.plugins/kubernetes-credentials-provider","source":"GHSA-2jpx-h8j2-g8m4"}],"prev":{"headline":"Session fixation vulnerability in Jenkins OpenId Connect Authentication Plugin","id":"CVE-2023-24424"},"products":["Jenkins Kubernetes Credentials Provider Plugin"],"published":"2023-01-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-02","vendors":["Jenkins Project"]},"summary":"Attackers with Item/Configure permission can access unauthorized Kubernetes credentials due to missing context in credential lookup.","url":"https://insights.sbomify.com/CVE-2023-24425/"}