# CVE-2023-24425: Exposure of system-scoped Kubernetes credentials in Jenkins Kubernetes Credentials Provider Plugin

> Attackers with Item/Configure permission can access unauthorized Kubernetes credentials due to missing context in credential lookup.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2023
- **Updated:** 2 Apr 2025
- **Also known as:** GHSA-2jpx-h8j2-g8m4

## What is CVE-2023-24425?

CVE-2023-24425 is a medium-severity missing authorization vulnerability in Jenkins Kubernetes Credentials Provider Plugin, published on 24 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Kubernetes Credentials Provider Plugin 1.208.v128ee9800c04 and earlier does not set the appropriate context for Kubernetes credentials lookup, allowing attackers with Item/Configure permission to access and potentially capture Kubernetes credentials they are not entitled to.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-24425?

2 open source packages ship an affected version, including com.cloudbees.jenkins.plugins:kubernetes-credentials-provider. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.cloudbees.jenkins.plugins:kubernetes-credentials-provider` | Maven | All versions | 1.209.v862c6e5fb |
| `com.cloudbees.jenkins.plugins:kubernetes-credentials-provider` | Maven | All versions | 1.209.v862c6e5fb |

Products: Jenkins Kubernetes Credentials Provider.

## How do I fix CVE-2023-24425?

Upgrade com.cloudbees.jenkins.plugins:kubernetes-credentials-provider to 1.209.v862c6e5fb or later.

## Is CVE-2023-24425 being exploited?

There is no known exploitation of CVE-2023-24425 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-24425 and fix it if it is affected.

What it is: CVE-2023-24425 is a medium-severity missing authorization vulnerability in Jenkins Kubernetes Credentials Provider Plugin, published on 24 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-24425 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.cloudbees.jenkins.plugins:kubernetes-credentials-provider (Maven): affected all versions; fixed in 1.209.v862c6e5fb
- com.cloudbees.jenkins.plugins:kubernetes-credentials-provider (Maven): affected all versions; fixed in 1.209.v862c6e5fb

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-24425/ (Markdown: https://insights.sbomify.com/CVE-2023-24425/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-24425
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-24425
- OSV: https://osv.dev/vulnerability/CVE-2023-24425

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-24425/
Summaries are generated and may contain mistakes; the official description above is the record.
