# CVE-2023-24456: Session fixation vulnerability in Jenkins Keycloak Authentication Plugin

> Attackers can hijack user sessions in Jenkins Keycloak Authentication Plugin by exploiting session fixation vulnerabilities.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2023
- **Updated:** 2 Apr 2025
- **Also known as:** GHSA-9963-gmh8-vvm6

## What is CVE-2023-24456?

CVE-2023-24456 is a critical authentication bypass vulnerability in Jenkins Keycloak Authentication Plugin, published on 24 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Keycloak Authentication Plugin 2.3.0 and earlier does not invalidate the previous session on login.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2023-24456?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:keycloak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:keycloak` | Maven | All versions | 2.3.1 |
| `org.jenkins-ci.plugins:keycloak` | Maven | All versions | 2.3.1 |

Products: Jenkins Keycloak Authentication.

## How do I fix CVE-2023-24456?

Upgrade org.jenkins-ci.plugins:keycloak to 2.3.1 or later.

## Is CVE-2023-24456 being exploited?

There is no known exploitation of CVE-2023-24456 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Keycloak Authentication Plugin

- [CVE-2023-24457](https://insights.sbomify.com/CVE-2023-24457/): CSRF vulnerability in Jenkins Keycloak Authentication Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-24456 and fix it if it is affected.

What it is: CVE-2023-24456 is a critical authentication bypass vulnerability in Jenkins Keycloak Authentication Plugin, published on 24 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-24456 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:keycloak (Maven): affected all versions; fixed in 2.3.1
- org.jenkins-ci.plugins:keycloak (Maven): affected all versions; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-24456/ (Markdown: https://insights.sbomify.com/CVE-2023-24456/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-24456
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-24456
- OSV: https://osv.dev/vulnerability/CVE-2023-24456

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-24456/
Summaries are generated and may contain mistakes; the official description above is the record.
