CVE-2023-24580 Resource exhaustion in Django
Attackers can cause denial of service in Django applications by sending multipart requests with excessive parts, leading to resource exhaustion.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-24580?
CVE-2023-24580 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 15 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0 before 4.0.10, and 4.1 before 4.1.7. Passing certain inputs (e.g., an excessive number of parts) to multipart forms could result in too many open files or memory exhaustion, and provided a potential vector for a denial-of-service attack.
Weakness: CWE-400
Which versions are affected by CVE-2023-24580?
8 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django Bitnami | From 3.2.0 | 3.2.18, 4.0.10, 4.1.7 |
django PyPI | From 3.2 | 3.2.18, 4.0.10, 4.1.7 |
django PyPI | From 3.2a1 | 3.2.18 |
django PyPI | From 4.0a1 | 4.0.10 |
django PyPI | From 4.1a1 | 4.1.7 |
Django PyPI | From 3.2a1 | 3.2.18 |
2 more packages
Django PyPI | From 4.0a1 | 4.0.10 |
Django PyPI | From 4.1a1 | 4.1.7 |
Linux distribution packages (10)
python-Django SUSE:HPE Helion OpenStack 8 | All versions | 1.11.29-3.45.1 |
python-Django SUSE:OpenStack Cloud 8 | All versions | 1.11.29-3.45.1 |
python-Django1 SUSE:OpenStack Cloud 9 | All versions | 1.11.29-3.44.1 |
python-Django SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.11.29-3.45.1 |
python-Django1 SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.11.29-3.44.1 |
python-Django SUSE:Package Hub 15 SP4 | All versions | 2.2.28-bp154.2.9.1 |
python-Django1 SUSE:Package Hub 15 SP4 | All versions | 1.11.29-bp154.2.3.1 |
python-Django openSUSE:Leap 15.4 | All versions | 2.2.28-bp154.2.9.1 |
python-Django1 openSUSE:Leap 15.4 | All versions | 1.11.29-bp154.2.3.1 |
python-Django openSUSE:Tumbleweed | All versions | 4.1.7-1.1 |
Products include Debian Debian Linux, Djangoproject Django.
How do I fix CVE-2023-24580?
Upgrade django to a fixed version for your release line: 3.2.18, 4.0.10 or 4.1.7.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-24580 being exploited?
There is no known exploitation of CVE-2023-24580 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-django-2023-24580, CVE-2022-24580, DEBIAN-CVE-2023-24580, DLA-3329-1, GHSA-2hrw-hx67-34x6, OESA-2023-1136 and 8 more.