# CVE-2023-24580: Resource exhaustion in Django

> Attackers can cause denial of service in Django applications by sending multipart requests with excessive parts, leading to resource exhaustion.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Feb 2023
- **Updated:** 18 Mar 2025
- **Also known as:** BIT-django-2023-24580, CVE-2022-24580, DEBIAN-CVE-2023-24580, DLA-3329-1, GHSA-2hrw-hx67-34x6, OESA-2023-1136, PYSEC-2023-13, SUSE-SU-2023:0704-1, SUSE-SU-2023:2080-1, UBUNTU-CVE-2023-24580, USN-5868-1, openSUSE-SU-2023:0062-1, openSUSE-SU-2023:0075-1, openSUSE-SU-2024:12690-1

## What is CVE-2023-24580?

CVE-2023-24580 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 15 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0 before 4.0.10, and 4.1 before 4.1.7. Passing certain inputs (e.g., an excessive number of parts) to multipart forms could result in too many open files or memory exhaustion, and provided a potential vector for a denial-of-service attack.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-24580?

8 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 3.2.0 | 3.2.18, 4.0.10, 4.1.7 |
| `django` | PyPI | From 3.2 | 3.2.18, 4.0.10, 4.1.7 |
| `django` | PyPI | From 3.2a1 | 3.2.18 |
| `django` | PyPI | From 4.0a1 | 4.0.10 |
| `django` | PyPI | From 4.1a1 | 4.1.7 |
| `Django` | PyPI | From 3.2a1 | 3.2.18 |
| `Django` | PyPI | From 4.0a1 | 4.0.10 |
| `Django` | PyPI | From 4.1a1 | 4.1.7 |
| `python-Django` | SUSE:HPE Helion OpenStack 8 | All versions | 1.11.29-3.45.1 |
| `python-Django` | SUSE:OpenStack Cloud 8 | All versions | 1.11.29-3.45.1 |
| `python-Django1` | SUSE:OpenStack Cloud 9 | All versions | 1.11.29-3.44.1 |
| `python-Django` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.11.29-3.45.1 |
| `python-Django1` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.11.29-3.44.1 |
| `python-Django` | SUSE:Package Hub 15 SP4 | All versions | 2.2.28-bp154.2.9.1 |
| `python-Django1` | SUSE:Package Hub 15 SP4 | All versions | 1.11.29-bp154.2.3.1 |
| `python-Django` | openSUSE:Leap 15.4 | All versions | 2.2.28-bp154.2.9.1 |
| `python-Django1` | openSUSE:Leap 15.4 | All versions | 1.11.29-bp154.2.3.1 |
| `python-Django` | openSUSE:Tumbleweed | All versions | 4.1.7-1.1 |

Products: Debian Debian Linux, Djangoproject Django.

## How do I fix CVE-2023-24580?

Upgrade django to a fixed version for your release line: 3.2.18, 4.0.10 or 4.1.7.

## Is CVE-2023-24580 being exploited?

There is no known exploitation of CVE-2023-24580 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-24580 and fix it if it is affected.

What it is: CVE-2023-24580 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 15 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-24580 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 3.2.0; fixed in 3.2.18, 4.0.10, 4.1.7
- django (PyPI): affected from 3.2; fixed in 3.2.18, 4.0.10, 4.1.7
- django (PyPI): affected from 3.2a1; fixed in 3.2.18
- django (PyPI): affected from 4.0a1; fixed in 4.0.10
- django (PyPI): affected from 4.1a1; fixed in 4.1.7
- Django (PyPI): affected from 3.2a1; fixed in 3.2.18
- Django (PyPI): affected from 4.0a1; fixed in 4.0.10
- Django (PyPI): affected from 4.1a1; fixed in 4.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-24580/ (Markdown: https://insights.sbomify.com/CVE-2023-24580/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-24580
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-24580
- OSV: https://osv.dev/vulnerability/CVE-2023-24580

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-24580/
Summaries are generated and may contain mistakes; the official description above is the record.
