{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-24607 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-24607 is a high-severity denial of service vulnerability in Qt Qt, published on 15 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-24607 and fix it if it is affected.\n\nWhat it is: CVE-2023-24607 is a high-severity denial of service vulnerability in Qt Qt, published on 15 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-24607 in the wild and no public exploit code.\n\nAffected product: Qt Qt. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-24607/ (Markdown: https://insights.sbomify.com/CVE-2023-24607/index.md)","id":"CVE-2023-24607","markdown":"https://insights.sbomify.com/CVE-2023-24607/index.md","name":"CVE-2023-24607","record":{"aliases":["AZL-26048","DEBIAN-CVE-2023-24607","GHSA-gfrv-8477-wf9f","OESA-2023-1270","OESA-2023-1295","OESA-2023-1296","OESA-2023-1490","SUSE-SU-2023:1567-1","UBUNTU-CVE-2023-24607","openSUSE-SU-2024:12673-1","openSUSE-SU-2024:12801-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Qt SQL ODBC plugin","requires_auth":"none","summary":"A crafted string causes a denial of service in the Qt SQL ODBC driver plugin when SQLTCHAR size is 4, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"qt","vendor":"qt"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"Qt before 6.4.3 allows a denial of service via a crafted string when the SQL ODBC driver plugin is used and the size of SQLTCHAR is 4. The affected versions are 5.x before 5.15.13, 6.x before 6.2.8, and 6.3.x before 6.4.3.","ecosystems":["SUSE:Linux Enterprise Module for Package Hub 15 SP4","openSUSE:Leap 15.4","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2023-24607","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"qt:qt","products":["qt:qt"],"type":"denial_of_service","year":"2023"},"n_packages":5,"n_references":8,"next":{"headline":"Matrix SSL 4.x through 4.6.0 and Rambus TLS Toolkit have a length-subtraction integer overflow for Client Hello Pre-Shared Key extension par","id":"CVE-2023-24609"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP4","fixed":["6.2.2-150400.4.3.1"],"introduced":["0"],"last_affected":[],"package":"qt6-base","purl":"pkg:rpm/suse/qt6-base\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP4","source":"SUSE-SU-2023:1567-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["6.2.2-150400.4.3.1"],"introduced":["0"],"last_affected":[],"package":"qt6-base","purl":"pkg:rpm/opensuse/qt6-base\u0026distro=openSUSE%20Leap%2015.4","source":"SUSE-SU-2023:1567-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["6.2.2-150400.4.3.1"],"introduced":["0"],"last_affected":[],"package":"qt6-base-docs","purl":"pkg:rpm/opensuse/qt6-base-docs\u0026distro=openSUSE%20Leap%2015.4","source":"SUSE-SU-2023:1567-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.15.8+kde183-1.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtbase","purl":"pkg:rpm/opensuse/libqt5-qtbase\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12801-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["6.4.2-2.1"],"introduced":["0"],"last_affected":[],"package":"qt6-base","purl":"pkg:rpm/opensuse/qt6-base\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12673-1"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2023-24605"},"products":["n/a"],"published":"2023-04-15","related":[{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2020-12267","kev_date_added":null,"published":"2020-04-27"},{"cvss_score":9.8,"headline":"Command injection in Qt for Android","id":"CVE-2017-10904","kev_date_added":null,"published":"2017-12-15"},{"cvss_score":9.3,"headline":"Memory corruption in n/a","id":"CVE-2011-3194","kev_date_added":null,"published":"2012-06-16"},{"cvss_score":8.8,"headline":"Integer overflow in Qt","id":"CVE-2022-40983","kev_date_added":null,"published":"2023-01-12"},{"cvss_score":8.8,"headline":"Memory corruption in Qt","id":"CVE-2022-43591","kev_date_added":null,"published":"2023-01-12"},{"cvss_score":8.6,"headline":"Race condition in n/a","id":"CVE-2024-39936","kev_date_added":null,"published":"2024-07-04"},{"cvss_score":8.6,"headline":"Denial of service in n/a","id":"CVE-2018-21035","kev_date_added":null,"published":"2020-02-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"A crafted string causes a denial of service in the Qt SQL ODBC driver plugin when SQLTCHAR size is 4, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2023-24607/"}