CVE-2023-24613 Memory corruption in n/a

Medium 4.9 Published Updated

Remote attackers with admin privileges can use gdb to corrupt the backend stack, causing a denial of service in Array Networks AG Series devices.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-24613?

CVE-2023-24613 is a medium-severity memory corruption vulnerability in n/a, published on 3 Feb 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

The user interface of Array Networks AG Series and vxAG through 9.4.0.470 could allow a remote attacker to use the gdb tool to overwrite the backend function call stack after accessing the system with administrator privileges. A successful exploit could leverage this vulnerability in the backend binary file that handles the user interface to a cause denial of service attack. This is fixed in AG 9.4.0.481.

Weakness: CWE-787

Which versions are affected by CVE-2023-24613?

It affects 1 product.

Products include Arraynetworks Arrayos Ag.

How do I fix CVE-2023-24613?

No fix has been published for CVE-2023-24613 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2023-24613 being exploited?

There is no known exploitation of CVE-2023-24613 in the wild and no public exploit code.

Sources

Also known as GHSA-h4g9-6mgj-wrmj.

Is CVE-2023-24613 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free