# CVE-2023-24613: Memory corruption in n/a

> Remote attackers with admin privileges can use gdb to corrupt the backend stack, causing a denial of service in Array Networks AG Series devices.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 Feb 2023
- **Updated:** 26 Mar 2025
- **Also known as:** GHSA-h4g9-6mgj-wrmj

## What is CVE-2023-24613?

CVE-2023-24613 is a medium-severity memory corruption vulnerability in n/a, published on 3 Feb 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The user interface of Array Networks AG Series and vxAG through 9.4.0.470 could allow a remote attacker to use the gdb tool to overwrite the backend function call stack after accessing the system with administrator privileges. A successful exploit could leverage this vulnerability in the backend binary file that handles the user interface to a cause denial of service attack. This is fixed in AG 9.4.0.481.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2023-24613?

It affects 1 product.


Products: Arraynetworks Arrayos Ag.

## How do I fix CVE-2023-24613?

No fix has been published for CVE-2023-24613 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-24613 being exploited?

There is no known exploitation of CVE-2023-24613 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-28461](https://insights.sbomify.com/CVE-2023-28461/): Array Networks AG and vxAG ArrayOS Missing Authentication for Critical Function (critical 9.8, exploited in the wild)
- [CVE-2025-66644](https://insights.sbomify.com/CVE-2025-66644/): Array Networks ArrayOS AG OS Command Injection (high 7.2, exploited in the wild)
- [CVE-2023-51707](https://insights.sbomify.com/CVE-2023-51707/): Command injection in n/a (critical 9.8)
- [CVE-2022-42897](https://insights.sbomify.com/CVE-2022-42897/): Command injection in n/a (critical 9.8)
- [CVE-2023-41121](https://insights.sbomify.com/CVE-2023-41121/): Denial of service in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-24613 and fix it if it is affected.

What it is: CVE-2023-24613 is a medium-severity memory corruption vulnerability in n/a, published on 3 Feb 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-24613 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-24613/ (Markdown: https://insights.sbomify.com/CVE-2023-24613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-24613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-24613
- OSV: https://osv.dev/vulnerability/CVE-2023-24613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-24613/
Summaries are generated and may contain mistakes; the official description above is the record.
