# CVE-2023-24623: Paranoidhttp Server-Side Request Forgery vulnerability

> An attacker can bypass private address filters in Paranoidhttp to perform Server-Side Request Forgery attacks against internal services.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2023
- **Updated:** 28 Mar 2025
- **Also known as:** GHSA-v9mp-j8g7-2q6m, GO-2023-1526

## What is CVE-2023-24623?

CVE-2023-24623 is a high-severity server-side request forgery vulnerability in n/a, published on 30 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Paranoidhttp before 0.3.0 allows SSRF because [::] is equivalent to the 127.0.0.1 address, but does not match the filter for private addresses.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-24623?

3 open source packages ship an affected version, including github.com/hakobe/paranoidhttp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hakobe/paranoidhttp` | Go | All versions | 0.3.0 |
| `github.com/hakobe/paranoidhttp` | Go | All versions | 0.3.0 |
| `github.com/hakobe/paranoidhttp` | Go | All versions | 0.3.0 |

Products: Paranoidhttp Project Paranoidhttp.

## How do I fix CVE-2023-24623?

Upgrade github.com/hakobe/paranoidhttp to 0.3.0 or later.

## Is CVE-2023-24623 being exploited?

There is no known exploitation of CVE-2023-24623 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-24623 and fix it if it is affected.

What it is: CVE-2023-24623 is a high-severity server-side request forgery vulnerability in n/a, published on 30 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-24623 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hakobe/paranoidhttp (Go): affected all versions; fixed in 0.3.0
- github.com/hakobe/paranoidhttp (Go): affected all versions; fixed in 0.3.0
- github.com/hakobe/paranoidhttp (Go): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-24623/ (Markdown: https://insights.sbomify.com/CVE-2023-24623/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-24623
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-24623
- OSV: https://osv.dev/vulnerability/CVE-2023-24623

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-24623/
Summaries are generated and may contain mistakes; the official description above is the record.
