CVE-2023-2478 Missing authorization in GitLab

Critical 9.6 Published Updated

Unauthorized users can attach malicious runners to projects via GraphQL, enabling code execution and privilege escalation in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-2478?

CVE-2023-2478 is a critical missing authorization vulnerability in Gitlab Gitlab, published on 8 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.4 before 15.9.7, all versions starting from 15.10 before 15.10.6, all versions starting from 15.11 before 15.11.2. Under certain conditions, a malicious unauthorized GitLab user may use a GraphQL endpoint to attach a malicious runner to any project.

Weakness: CWE-732

Which versions are affected by CVE-2023-2478?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.4.015.9.7, 15.10.6, 15.11.2

Products include Gitlab Gitlab.

How do I fix CVE-2023-2478?

Upgrade gitlab to a fixed version for your release line: 15.9.7, 15.10.6 or 15.11.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-2478 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2478 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2023-2478, GHSA-7h3w-v9hh-hp55, UBUNTU-CVE-2023-2478.

Is CVE-2023-2478 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free