CVE-2023-24809 NetHack Call command buffer overflow

Medium 5.5 Published Updated

A buffer overflow in the NetHack game allows attackers to crash the process or potentially escalate privileges on systems with suid/sgid permissions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2023-24809?

CVE-2023-24809 is a medium-severity memory corruption vulnerability in NetHack, published on 17 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

NetHack is a single player dungeon exploration game. Starting with version 3.6.2 and prior to version 3.6.7, illegal input to the "C" (call) command can cause a buffer overflow and crash the NetHack process. This vulnerability may be a security issue for systems that have NetHack installed suid/sgid and for shared systems. For all systems, it may result in a process crash. This issue is resolved in NetHack 3.6.7. There are no known workarounds.

Weakness: CWE-120

Which versions are affected by CVE-2023-24809?

It affects 1 product.

Products include Nethack Nethack.

How do I fix CVE-2023-24809?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2023-24809 being exploited?

There is no known exploitation of CVE-2023-24809 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2023-24809, GHSA-2cqv-5w4v-mgch, UBUNTU-CVE-2023-24809.

Is CVE-2023-24809 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free