{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-24809 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-24809 is a medium-severity memory corruption vulnerability in NetHack, published on 17 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-24809 and fix it if it is affected.\n\nWhat it is: CVE-2023-24809 is a medium-severity memory corruption vulnerability in NetHack, published on 17 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-24809 in the wild and no public exploit code.\n\nAffected product: NetHack. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-24809/ (Markdown: https://insights.sbomify.com/CVE-2023-24809/index.md)","id":"CVE-2023-24809","markdown":"https://insights.sbomify.com/CVE-2023-24809/index.md","name":"CVE-2023-24809","record":{"aliases":["DEBIAN-CVE-2023-24809","GHSA-2cqv-5w4v-mgch","UBUNTU-CVE-2023-24809"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["denial_of_service","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"NetHack game","requires_auth":"low_privilege","summary":"A buffer overflow in the NetHack game allows attackers to crash the process or potentially escalate privileges on systems with suid/sgid permissions.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"nethack","vendor":"nethack"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"NetHack is a single player dungeon exploration game. Starting with version 3.6.2 and prior to version 3.6.7, illegal input to the \"C\" (call) command can cause a buffer overflow and crash the NetHack process. This vulnerability may be a security issue for systems that have NetHack installed suid/sgid and for shared systems. For all systems, it may result in a process crash. This issue is resolved in NetHack 3.6.7. There are no known workarounds.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NetHack Call command buffer overflow","id":"CVE-2023-24809","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2023"},"n_packages":0,"n_references":2,"next":{"headline":"Cross site scripting (XSS) vulnerability using authentication callback in Misskey","id":"CVE-2023-24810"},"packages":[],"prev":{"headline":"Denial Of Service when opening a corrupt PDF file in pdfio","id":"CVE-2023-24808"},"products":["NetHack"],"published":"2023-02-17","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2019-19905","kev_date_added":null,"published":"2019-12-19"},{"cvss_score":5,"headline":"NetHack command line parsing of options starting with -de and -i is subject to a buffer overflow","id":"CVE-2020-5209","kev_date_added":null,"published":"2020-01-28"},{"cvss_score":5,"headline":"NetHack command line -w option parsing is subject to a buffer overflow","id":"CVE-2020-5210","kev_date_added":null,"published":"2020-01-28"},{"cvss_score":5,"headline":"NetHack AUTOCOMPLETE configuration file option is subject to a buffer overflow","id":"CVE-2020-5211","kev_date_added":null,"published":"2020-01-28"},{"cvss_score":5,"headline":"NetHack MENUCOLOR configuration file option is subject to a buffer overflow","id":"CVE-2020-5212","kev_date_added":null,"published":"2020-01-28"},{"cvss_score":5,"headline":"NetHack SYMBOL configuration file option is subject to a buffer overflow","id":"CVE-2020-5213","kev_date_added":null,"published":"2020-01-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["NetHack"]},"summary":"A buffer overflow in the NetHack game allows attackers to crash the process or potentially escalate privileges on systems with suid/sgid permissions.","url":"https://insights.sbomify.com/CVE-2023-24809/"}