# CVE-2023-24813: URI validation failure on SVG parsing. Bypass of CVE-2023-23924

> Attacker can bypass URI validation in Dompdf to trigger SSRF and potential remote code execution via malicious SVG files.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** DEBIAN-CVE-2023-24813, GHSA-56gj-mvh6-rp75

## What is CVE-2023-24813?

CVE-2023-24813 is a critical server-side request forgery vulnerability in dompdf, published on 7 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dompdf is an HTML to PDF converter written in php. Due to the difference in the attribute parser of Dompdf and php-svg-lib, an attacker can still call arbitrary URLs with arbitrary protocols. Dompdf parses the href attribute of `image` tags and respects `xlink:href` even if `href` is specified. However, php-svg-lib, which is later used to parse the svg file, parses the href attribute. Since `href` is respected if both `xlink:href` and `href` is specified, it's possible to bypass the protection on the Dompdf side by providing an empty `xlink:href` attribute. An attacker can exploit the vulnerability to call arbitrary URLs with arbitrary protocols if they provide an SVG file to the Dompdf. In PHP versions before 8.0.0, it leads to arbitrary unserialize, which will lead, at the very least, to arbitrary file deletion and might lead to remote code execution, depending on available classes. This vulnerability has been addressed in commit `95009ea98` which has been included in release version 2.0.3. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2023-24813?

2 open source packages ship an affected version, including dompdf/dompdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dompdf/dompdf` | Packagist | From 2.0.2 | 2.0.3 |
| `dompdf/dompdf` | Packagist | From 2.0.2 | 2.0.3 |

Products: Dompdf Project Dompdf.

## How do I fix CVE-2023-24813?

Upgrade dompdf/dompdf to 2.0.3 or later.

## Is CVE-2023-24813 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-24813 exists.

## Other vulnerabilities in dompdf

- [CVE-2023-23924](https://insights.sbomify.com/CVE-2023-23924/): URI validation failure on SVG parsing in Dompdf (critical 10.0)
- [CVE-2021-3838](https://insights.sbomify.com/CVE-2021-3838/): PHAR Deserialization in dompdf/dompdf (critical 9.8)
- [CVE-2021-3902](https://insights.sbomify.com/CVE-2021-3902/): Improper Restriction of XML External Entity Reference in dompdf/dompdf (critical 9.8)
- [CVE-2022-28368](https://insights.sbomify.com/CVE-2022-28368/): Remote code injection in dompdf/dompdf (critical 9.8)
- [CVE-2014-5013](https://insights.sbomify.com/CVE-2014-5013/): DOMPDF Remote Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-24813 and fix it if it is affected.

What it is: CVE-2023-24813 is a critical server-side request forgery vulnerability in dompdf, published on 7 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-24813 exists.

Affected packages and fixed versions:
- dompdf/dompdf (Packagist): affected from 2.0.2; fixed in 2.0.3
- dompdf/dompdf (Packagist): affected from 2.0.2; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-24813/ (Markdown: https://insights.sbomify.com/CVE-2023-24813/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-24813
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-24813
- OSV: https://osv.dev/vulnerability/CVE-2023-24813

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-24813/
Summaries are generated and may contain mistakes; the official description above is the record.
