# CVE-2023-24824: Quadratic complexity may lead to a denial of service in cmark-gfm

> Attackers can cause denial of service in cmark-gfm by submitting crafted input with excessive characters, leading to resource exhaustion.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2023
- **Updated:** 11 Feb 2025
- **Also known as:** ALSA-2025:8427, DEBIAN-CVE-2023-24824, GHSA-66g8-4hjf-77xh, HSEC-2025-0007, RHSA-2025:8427, RLSA-2025:8427, UBUNTU-CVE-2023-24824

## What is CVE-2023-24824?

CVE-2023-24824 is a medium-severity denial of service vulnerability in github cmark-gfm, published on 31 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

cmark-gfm is GitHub's fork of cmark, a CommonMark parsing and rendering library and program in C. A polynomial time complexity issue in cmark-gfm may lead to unbounded resource exhaustion and subsequent denial of service. This CVE covers quadratic complexity issues when parsing text which leads with either large numbers of `>` or `-` characters. This issue has been addressed in version 0.29.0.gfm.10. Users are advised to upgrade. Users unable to upgrade should validate that their input comes from trusted sources.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-24824?

1 open source package ship an affected version, including cmark-gfm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cmark-gfm` | Hackage | From 0.1.0 | 0.2.6 |
| `pandoc` | AlmaLinux:8 | All versions | 2.0.6-7.el8_10 |
| `pandoc-common` | AlmaLinux:8 | All versions | 2.0.6-7.el8_10 |
| `pandoc` | Red Hat:enterprise_linux:8::crb | All versions | 0:2.0.6-7.el8_10 |
| `pandoc-common` | Red Hat:enterprise_linux:8::crb | All versions | 0:2.0.6-7.el8_10 |
| `pandoc` | Rocky Linux:8 | All versions | 0:2.0.6-7.el8_10 |

Products: Github Cmark-Gfm.

## How do I fix CVE-2023-24824?

Upgrade cmark-gfm to 0.2.6 or later.

## Is CVE-2023-24824 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-24824 exists.

## Other vulnerabilities in github cmark-gfm

- [CVE-2024-22051](https://insights.sbomify.com/CVE-2024-22051/): CommonMarker Integer Overflow Vulnerability (critical 9.8)
- [CVE-2023-37463](https://insights.sbomify.com/CVE-2023-37463/): Quadratic complexity bugs may lead to a denial of service (medium 6.4)
- [CVE-2023-26485](https://insights.sbomify.com/CVE-2023-26485/): Quadratic complexity may lead to a denial of service in cmark-gfm (medium 5.3)
- [CVE-2023-22485](https://insights.sbomify.com/CVE-2023-22485/): cmark-gfm out-of-bounds read in validate_protocol (medium 5.3)
- [CVE-2023-22486](https://insights.sbomify.com/CVE-2023-22486/): cmark-gfm Quadratic complexity bug in handle_close_bracket may lead to a denial of service (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-24824 and fix it if it is affected.

What it is: CVE-2023-24824 is a medium-severity denial of service vulnerability in github cmark-gfm, published on 31 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-24824 exists.

Affected packages and fixed versions:
- cmark-gfm (Hackage): affected from 0.1.0; fixed in 0.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-24824/ (Markdown: https://insights.sbomify.com/CVE-2023-24824/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-24824
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-24824
- OSV: https://osv.dev/vulnerability/CVE-2023-24824

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-24824/
Summaries are generated and may contain mistakes; the official description above is the record.
