# CVE-2023-24825: RIOT-OS vulnerable to NULL pointer dereference in gnrc_pktbuf_mark

> An attacker can cause a denial of service in RIOT-OS by sending a crafted 6LoWPAN frame that triggers a NULL pointer dereference.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 May 2023
- **Updated:** 10 Jan 2025
- **Also known as:** GHSA-xqm8-xj74-fjw2

## What is CVE-2023-24825?

CVE-2023-24825 is a high-severity vulnerability in RIOT-OS RIOT, published on 30 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RIOT-OS, an operating system for Internet of Things (IoT) devices, contains a network stack with the ability to process 6LoWPAN frames. Prior to version 2023.04, an attacker can send a crafted frame to the device to trigger a NULL pointer dereference leading to denial of service. This issue is fixed in version 2023.04. There are no known workarounds.

Weakness: CWE-476 (NULL Pointer Dereference), CWE-252 (Unchecked Return Value)

## Which versions are affected by CVE-2023-24825?

It affects 1 product.


Products: Riot-Os Riot.

## How do I fix CVE-2023-24825?

No fix has been published for CVE-2023-24825 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-24825 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-24825 exists.

## Other vulnerabilities in RIOT-OS RIOT

- [CVE-2024-32017](https://insights.sbomify.com/CVE-2024-32017/): Buffer overflows in RIOT (critical 9.8)
- [CVE-2023-33975](https://insights.sbomify.com/CVE-2023-33975/): RIOT-OS vulnerable to Out of Bounds Write in _rbuf_add (critical 9.8)
- [CVE-2023-24819](https://insights.sbomify.com/CVE-2023-24819/): RIOT-OS vulnerable to Buffer Overflow during IPHC receive (critical 9.8)
- [CVE-2023-24823](https://insights.sbomify.com/CVE-2023-24823/): RIOT-OS vulnerable to Packet Type Confusion during IPHC send (critical 9.8)
- [CVE-2021-27357](https://insights.sbomify.com/CVE-2021-27357/): Memory corruption in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-24825 and fix it if it is affected.

What it is: CVE-2023-24825 is a high-severity vulnerability in RIOT-OS RIOT, published on 30 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-24825 exists.

Affected product: RIOT-OS RIOT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-24825/ (Markdown: https://insights.sbomify.com/CVE-2023-24825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-24825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-24825
- OSV: https://osv.dev/vulnerability/CVE-2023-24825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-24825/
Summaries are generated and may contain mistakes; the official description above is the record.
