CVE-2023-2485 Incorrect Privilege Assignment in GitLab
A malicious maintainer can escalate other users to Owners in a project by importing members from another project where those users are already Owners.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-2485?
CVE-2023-2485 is a medium-severity vulnerability in Gitlab Gitlab, published on 7 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 14.1 before 15.10.8, all versions starting from 15.11 before 15.11.7, all versions starting from 16.0 before 16.0.2. A malicious maintainer in a project can escalate other users to Owners in that project if they import members from another project that those other users are Owners of.
Weakness: CWE-266
Which versions are affected by CVE-2023-2485?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 14.1.0 | 15.10.8, 15.11.7, 16.0.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2023-2485?
Upgrade gitlab to a fixed version for your release line: 15.10.8, 15.11.7 or 16.0.2.
Is CVE-2023-2485 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2485 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2023-2485, GHSA-g9jp-p8w6-7f2q, UBUNTU-CVE-2023-2485.