# CVE-2023-2485: Incorrect Privilege Assignment in GitLab

> A malicious maintainer can escalate other users to Owners in a project by importing members from another project where those users are already Owners.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2023
- **Updated:** 7 Jan 2025
- **Also known as:** BIT-gitlab-2023-2485, GHSA-g9jp-p8w6-7f2q, UBUNTU-CVE-2023-2485

## What is CVE-2023-2485?

CVE-2023-2485 is a medium-severity vulnerability in Gitlab Gitlab, published on 7 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 14.1 before 15.10.8, all versions starting from 15.11 before 15.11.7, all versions starting from 16.0 before 16.0.2. A malicious maintainer in a project can escalate other users to Owners in that project if they import members from another project that those other users are Owners of.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2023-2485?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 14.1.0 | 15.10.8, 15.11.7, 16.0.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2023-2485?

Upgrade gitlab to a fixed version for your release line: 15.10.8, 15.11.7 or 16.0.2.

## Is CVE-2023-2485 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2485 exists.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2485 and fix it if it is affected.

What it is: CVE-2023-2485 is a medium-severity vulnerability in Gitlab Gitlab, published on 7 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2485 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 14.1.0; fixed in 15.10.8, 15.11.7, 16.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2485/ (Markdown: https://insights.sbomify.com/CVE-2023-2485/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2485
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2485
- OSV: https://osv.dev/vulnerability/CVE-2023-2485

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2485/
Summaries are generated and may contain mistakes; the official description above is the record.
