# CVE-2023-25015: Clockwork Web contains a Cross-Site Request Forgery Vulnerability with Rails < 5.2

> An attacker can perform cross-site request forgery attacks against applications using Clockwork Web with older Rails versions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Feb 2023
- **Updated:** 26 Mar 2025
- **Also known as:** GHSA-p4xx-w6fr-c4w9

## What is CVE-2023-25015?

CVE-2023-25015 is a medium-severity vulnerability in n/a, published on 2 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Clockwork Web before 0.1.2, when Rails before 5.2 is used, allows CSRF.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-652 (Improper Neutralization of Data within XQuery Expressions)

## Which versions are affected by CVE-2023-25015?

2 open source packages ship an affected version, including clockwork_web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `clockwork_web` | RubyGems | All versions | 0.1.2 |
| `clockwork_web` | RubyGems | All versions | 0.1.2 |

Products: Clockwork Web Project Clockwork Web.

## How do I fix CVE-2023-25015?

Upgrade clockwork_web to 0.1.2 or later.

## Is CVE-2023-25015 being exploited?

There is no known exploitation of CVE-2023-25015 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25015 and fix it if it is affected.

What it is: CVE-2023-25015 is a medium-severity vulnerability in n/a, published on 2 Feb 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-25015 in the wild and no public exploit code.

Affected packages and fixed versions:
- clockwork_web (RubyGems): affected all versions; fixed in 0.1.2
- clockwork_web (RubyGems): affected all versions; fixed in 0.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25015/ (Markdown: https://insights.sbomify.com/CVE-2023-25015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25015
- OSV: https://osv.dev/vulnerability/CVE-2023-25015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25015/
Summaries are generated and may contain mistakes; the official description above is the record.
