CVE-2023-25135 Deserialization in n/a
Unauthenticated attackers can execute arbitrary code on vBulletin forums via crafted HTTP requests exploiting unsafe deserialization.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2023-25135?
CVE-2023-25135 is a critical unsafe deserialization vulnerability in Vbulletin Vbulletin, published on 3 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
vBulletin before 5.6.9 PL1 allows an unauthenticated remote attacker to execute arbitrary code via a crafted HTTP request that triggers deserialization. This occurs because verify_serialized checks that a value is serialized by calling unserialize and then checking for errors. The fixed versions are 5.6.7 PL1, 5.6.8 PL1, and 5.6.9 PL1.
Weakness: CWE-502
Which versions are affected by CVE-2023-25135?
It affects 1 product.
Products include Vbulletin Vbulletin.
How do I fix CVE-2023-25135?
No fix has been published for CVE-2023-25135 yet. Limit exposure of the affected software until one is available.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2023-25135 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-25135 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in Vbulletin Vbulletin
- CVE-2020-17496 vBulletin PHP Module Remote Code Execution
- CVE-2019-16759 vBulletin PHP Module Remote Code Execution
- CVE-2025-48827 vBulletin 5.0.0 through 5.7.5 and 6.0.0 through 6.0.3 allows unauthenticated users to invoke protected API controllers' methods when running
- CVE-2020-7373 Code injection in n/a
- CVE-2020-12720 SQL injection in n/a
Sources
Also known as GHSA-r8jw-f89q-p7g6.