CVE-2023-25141 JNDI injection into Apache sling-org-apache-sling-jcr-base

High 7.5 Published Updated

Attackers can execute arbitrary code via JNDI injection in Apache Sling JCR Base when using vulnerable JDK versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-25141?

CVE-2023-25141 is a high-severity code injection vulnerability in Apache Sling JCR Base, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache Sling JCR Base < 3.1.12 has a critical injection vulnerability when running on old JDK versions (JDK 1.8.191 or earlier) through utility functions in RepositoryAccessor. The functions getRepository and getRepositoryFromURL allow an application to access data stored in a remote location via JDNI and RMI.

Users of Apache Sling JCR Base are recommended to upgrade to Apache Sling JCR Base 3.1.12 or later, or to run on a more recent JDK.

Weakness: CWE-74

Which versions are affected by CVE-2023-25141?

2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.jcr.base. It affects 1 product.

PackageAffectedFixed in
org.apache.sling:org.apache.sling.jcr.base MavenAll versions3.1.12
org.apache.sling:org.apache.sling.jcr.base MavenAll versions3.1.12

Products include Apache Sling Jcr Base.

How do I fix CVE-2023-25141?

Upgrade org.apache.sling:org.apache.sling.jcr.base to 3.1.12 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2023-25141 being exploited?

There is no known exploitation of CVE-2023-25141 in the wild and no public exploit code.

Sources

Also known as GHSA-gvg3-83q4-rfhq.

Is CVE-2023-25141 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free