{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.jcr.base. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-25141 in the wild and no public exploit code.","fix":"Upgrade org.apache.sling:org.apache.sling.jcr.base to 3.1.12 or later.","what":"CVE-2023-25141 is a high-severity code injection vulnerability in Apache Sling JCR Base, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-25141 and fix it if it is affected.\n\nWhat it is: CVE-2023-25141 is a high-severity code injection vulnerability in Apache Sling JCR Base, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-25141 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.sling:org.apache.sling.jcr.base (Maven): affected all versions; fixed in 3.1.12\n- org.apache.sling:org.apache.sling.jcr.base (Maven): affected all versions; fixed in 3.1.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-25141/ (Markdown: https://insights.sbomify.com/CVE-2023-25141/index.md)","id":"CVE-2023-25141","markdown":"https://insights.sbomify.com/CVE-2023-25141/index.md","name":"CVE-2023-25141","record":{"aliases":["GHSA-gvg3-83q4-rfhq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Sling JCR Base","requires_auth":"none","summary":"Attackers can execute arbitrary code via JNDI injection in Apache Sling JCR Base when using vulnerable JDK versions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"sling_jcr_base","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Apache Sling JCR Base \u003c 3.1.12 has a critical injection vulnerability when running on old JDK versions (JDK 1.8.191 or earlier) through utility functions in RepositoryAccessor. The functions getRepository and getRepositoryFromURL allow an application to access data stored in a remote location via JDNI and RMI.\n\nUsers of Apache Sling JCR Base are recommended to upgrade to Apache Sling JCR Base 3.1.12 or later, or to run on a more recent JDK.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"JNDI injection into Apache sling-org-apache-sling-jcr-base","id":"CVE-2023-25141","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Path traversal in Trend Micro Apex One","id":"CVE-2023-25143"},"packages":[{"ecosystem":"Maven","fixed":["3.1.12"],"introduced":["0"],"last_affected":[],"package":"org.apache.sling:org.apache.sling.jcr.base","purl":null,"source":"GHSA-gvg3-83q4-rfhq"},{"ecosystem":"Maven","fixed":["3.1.12"],"introduced":["0"],"last_affected":[],"package":"org.apache.sling:org.apache.sling.jcr.base","purl":"pkg:maven/org.apache.sling/org.apache.sling.jcr.base","source":"GHSA-gvg3-83q4-rfhq"}],"prev":{"headline":"Memory corruption in Parasolid V34.0","id":"CVE-2023-25140"},"products":["Apache Sling JCR Base"],"published":"2023-02-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-20","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary code via JNDI injection in Apache Sling JCR Base when using vulnerable JDK versions.","url":"https://insights.sbomify.com/CVE-2023-25141/"}