# CVE-2023-25141: JNDI injection into Apache sling-org-apache-sling-jcr-base

> Attackers can execute arbitrary code via JNDI injection in Apache Sling JCR Base when using vulnerable JDK versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2023
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-gvg3-83q4-rfhq

## What is CVE-2023-25141?

CVE-2023-25141 is a high-severity code injection vulnerability in Apache Sling JCR Base, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Sling JCR Base < 3.1.12 has a critical injection vulnerability when running on old JDK versions (JDK 1.8.191 or earlier) through utility functions in RepositoryAccessor. The functions getRepository and getRepositoryFromURL allow an application to access data stored in a remote location via JDNI and RMI.

Users of Apache Sling JCR Base are recommended to upgrade to Apache Sling JCR Base 3.1.12 or later, or to run on a more recent JDK.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-25141?

2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.jcr.base. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.sling:org.apache.sling.jcr.base` | Maven | All versions | 3.1.12 |
| `org.apache.sling:org.apache.sling.jcr.base` | Maven | All versions | 3.1.12 |

Products: Apache Sling Jcr Base.

## How do I fix CVE-2023-25141?

Upgrade org.apache.sling:org.apache.sling.jcr.base to 3.1.12 or later.

## Is CVE-2023-25141 being exploited?

There is no known exploitation of CVE-2023-25141 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25141 and fix it if it is affected.

What it is: CVE-2023-25141 is a high-severity code injection vulnerability in Apache Sling JCR Base, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25141 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.sling:org.apache.sling.jcr.base (Maven): affected all versions; fixed in 3.1.12
- org.apache.sling:org.apache.sling.jcr.base (Maven): affected all versions; fixed in 3.1.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25141/ (Markdown: https://insights.sbomify.com/CVE-2023-25141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25141
- OSV: https://osv.dev/vulnerability/CVE-2023-25141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25141/
Summaries are generated and may contain mistakes; the official description above is the record.
