# CVE-2023-25149: TimescaleDB has incorrect access control

> Attackers can escalate privileges by exploiting insecure search_path in TimescaleDB telemetry jobs during installation, requiring specific user permissions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** BIT-timescaledb-2023-25149, GHSA-44jh-j22r-33wq

## What is CVE-2023-25149?

CVE-2023-25149 is a high-severity vulnerability in timescaledb, published on 14 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

TimescaleDB, an open-source time-series SQL database, has a privilege escalation vulnerability in versions 2.8.0 through 2.9.2. During installation, TimescaleDB creates a telemetry job that is runs as the installation user. The queries run as part of the telemetry data collection were not run with a locked down `search_path`, allowing malicious users to create functions that would be executed by the telemetry job, leading to privilege escalation. In order to be able to take advantage of this vulnerability, a user would need to be able to create objects in a database and then get a superuser to install TimescaleDB into their database. When TimescaleDB is installed as trusted extension, non-superusers can install the extension without help from a superuser.

Version 2.9.3 fixes this issue. As a mitigation, the `search_path` of the user running the telemetry job can be locked down to not include schemas writable by other users. The vulnerability is not exploitable on instances in Timescale Cloud and Managed Service for TimescaleDB due to additional security provisions in place on those platforms.

Weakness: CWE-269 (Improper Privilege Management), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-25149?

1 open source package ship an affected version, including timescaledb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `timescaledb` | Bitnami | From 2.8.0 | 2.9.2 |

Products: Timescale Timescaledb.

## How do I fix CVE-2023-25149?

Upgrade timescaledb to 2.9.2 or later.

## Is CVE-2023-25149 being exploited?

There is no known exploitation of CVE-2023-25149 in the wild and no public exploit code.

## Other vulnerabilities in timescaledb

- [CVE-2026-29089](https://insights.sbomify.com/CVE-2026-29089/): TimescaleDB uses untrusted search path during extension upgrade (high 8.8)
- [CVE-2022-24128](https://insights.sbomify.com/CVE-2022-24128/): Privilege escalation in n/a (high 8.0)
- [CVE-2026-70634](https://insights.sbomify.com/CVE-2026-70634/): TimescaleDB 2.29.1 Out-of-Bounds Read Information Disclosure via Dictionary Compression Reverse Iterator (high 7.2)
- [CVE-2026-70633](https://insights.sbomify.com/CVE-2026-70633/): TimescaleDB 2.29.1 Out-of-Bounds Read DoS via Gorilla Compression Reverse Iterator (high 7.1)
- [CVE-2026-70635](https://insights.sbomify.com/CVE-2026-70635/): TimescaleDB 2.29.1 Out-of-Bounds Read DoS via Bulk Dictionary Decompression Negative Index (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25149 and fix it if it is affected.

What it is: CVE-2023-25149 is a high-severity vulnerability in timescaledb, published on 14 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25149 in the wild and no public exploit code.

Affected packages and fixed versions:
- timescaledb (Bitnami): affected from 2.8.0; fixed in 2.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25149/ (Markdown: https://insights.sbomify.com/CVE-2023-25149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25149
- OSV: https://osv.dev/vulnerability/CVE-2023-25149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25149/
Summaries are generated and may contain mistakes; the official description above is the record.
