# CVE-2023-25153: containerd OCI image importer memory exhaustion

> A maliciously crafted OCI image can cause memory exhaustion and denial of service in containerd during import.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** AZL-13571, AZL-13584, AZL-13674, AZL-35000, CLEANSTART-2025-OB15168, DEBIAN-CVE-2023-25153, GHSA-259w-8hf6-59c2, GO-2023-1573, UBUNTU-CVE-2023-25153

## What is CVE-2023-25153?

CVE-2023-25153 is a medium-severity denial of service vulnerability in containerd, published on 16 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

containerd is an open source container runtime. Before versions 1.6.18 and 1.5.18, when importing an OCI image, there was no limit on the number of bytes read for certain files. A maliciously crafted image with a large file where a limit was not applied could cause a denial of service. This bug has been fixed in containerd 1.6.18 and 1.5.18.  Users should update to these versions to resolve the issue. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-25153?

5 open source packages ship an affected version, including github.com/containerd/containerd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containerd/containerd` | Go | All versions | 1.5.18, 1.6.18 |
| `github.com/containerd/containerd` | Go | All versions | 1.5.18 |
| `github.com/containerd/containerd` | Go | All versions | 1.5.18 |
| `github.com/containerd/containerd` | Go | From 1.6.0 | 1.6.18 |
| `github.com/containerd/containerd` | Go | From 1.6.0 | 1.6.18 |

Products: Linuxfoundation Containerd.

## How do I fix CVE-2023-25153?

Upgrade github.com/containerd/containerd to a fixed version for your release line: 1.5.18 or 1.6.18.

## Is CVE-2023-25153 being exploited?

There is no known exploitation of CVE-2023-25153 in the wild and no public exploit code.

## Other vulnerabilities in containerd

- [CVE-2026-53488](https://insights.sbomify.com/CVE-2026-53488/): containerd CRI — image-config `LABEL` flows to restart-monitor `binary://` logger: host-root command execution from an image pull (critical 9.4)
- [CVE-2026-53492](https://insights.sbomify.com/CVE-2026-53492/): containerd CRI checkpoint restore CDI annotation smuggling (high 8.4)
- [CVE-2026-53489](https://insights.sbomify.com/CVE-2026-53489/): containerd: Arbitrary host CRI log file read via symlink following in CRI checkpoint restore (high 8.2)
- [CVE-2025-47290](https://insights.sbomify.com/CVE-2025-47290/): Containerd vulnerable to host filesystem access during image unpack (high 7.6)
- [CVE-2026-46680](https://insights.sbomify.com/CVE-2026-46680/): containerd user ID handling bypass allows runAsNonRoot evasion (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25153 and fix it if it is affected.

What it is: CVE-2023-25153 is a medium-severity denial of service vulnerability in containerd, published on 16 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25153 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.5.18, 1.6.18
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.5.18
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.5.18
- github.com/containerd/containerd (Go): affected from 1.6.0; fixed in 1.6.18
- github.com/containerd/containerd (Go): affected from 1.6.0; fixed in 1.6.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25153/ (Markdown: https://insights.sbomify.com/CVE-2023-25153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25153
- OSV: https://osv.dev/vulnerability/CVE-2023-25153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25153/
Summaries are generated and may contain mistakes; the official description above is the record.
