# CVE-2023-25156: Kiwi TCMS has no protection against brute-force attacks on login page

> Attackers can brute-force login credentials due to missing rate limits, potentially taking over accounts in Kiwi TCMS.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-7968-h4m4-ghm9, PYSEC-2026-835

## What is CVE-2023-25156?

CVE-2023-25156 is a high-severity vulnerability in kiwitcms kiwi, published on 15 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kiwi TCMS, an open source test management system, does not impose rate limits in versions prior to 12.0. This makes it easier to attempt brute-force attacks against the login page. Users should upgrade to v12.0 or later to receive a patch. As a workaround, users may install and configure a rate-limiting proxy in front of Kiwi TCMS.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts), CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-25156?

3 open source packages ship an affected version, including kiwitcms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kiwitcms` | PyPI | All versions | 12.0 |
| `kiwitcms` | PyPI | All versions | 12.0 |
| `kiwitcms` | PyPI | All versions | 12.0 |

Products: Kiwitcms Kiwi Tcms.

## How do I fix CVE-2023-25156?

Upgrade kiwitcms to 12.0 or later.

## Is CVE-2023-25156 being exploited?

There is no known exploitation of CVE-2023-25156 in the wild and no public exploit code.

## Other vulnerabilities in kiwitcms kiwi

- [CVE-2023-30628](https://insights.sbomify.com/CVE-2023-30628/): Kiwi TCMS has command injection vulnerability in changelog.yml CI workflow (high 8.8)
- [CVE-2023-36809](https://insights.sbomify.com/CVE-2023-36809/): Kiwi TCMS's misconfigured HTTP headers allow stored XSS execution with Firefox (high 8.1)
- [CVE-2023-33977](https://insights.sbomify.com/CVE-2023-33977/): Stored cross site scripting (XSS) via unrestricted file upload in Kiwi TCMS (high 8.1)
- [CVE-2023-32686](https://insights.sbomify.com/CVE-2023-32686/): kiwitcms vulnerable to stored XSS via unrestricted files upload (high 8.1)
- [CVE-2023-30613](https://insights.sbomify.com/CVE-2023-30613/): Kiwi TCMS unrestricted file upload vulnerability (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25156 and fix it if it is affected.

What it is: CVE-2023-25156 is a high-severity vulnerability in kiwitcms kiwi, published on 15 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-25156 in the wild and no public exploit code.

Affected packages and fixed versions:
- kiwitcms (PyPI): affected all versions; fixed in 12.0
- kiwitcms (PyPI): affected all versions; fixed in 12.0
- kiwitcms (PyPI): affected all versions; fixed in 12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25156/ (Markdown: https://insights.sbomify.com/CVE-2023-25156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25156
- OSV: https://osv.dev/vulnerability/CVE-2023-25156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25156/
Summaries are generated and may contain mistakes; the official description above is the record.
