# CVE-2023-25170: PrestaShop has possible CSRF token fixation

> Attackers can bypass CSRF protection by fixing tokens during login, potentially allowing unauthorized actions on behalf of authenticated users.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-3g43-x7qr-96ph

## What is CVE-2023-25170?

CVE-2023-25170 is a medium-severity vulnerability in Prestashop Prestashop, published on 13 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PrestaShop is an open source e-commerce web application that, prior to version 8.0.1, is vulnerable to cross-site request forgery (CSRF). When authenticating users, PrestaShop preserves session attributes. Because this does not clear CSRF tokens upon login, this might enable same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation. The problem is fixed in version 8.0.1.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-25170?

2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | All versions | 8.0.1 |
| `prestashop/prestashop` | Packagist | All versions | 8.0.1 |

Products: Prestashop Prestashop.

## How do I fix CVE-2023-25170?

Upgrade prestashop/prestashop to 8.0.1 or later.

## Is CVE-2023-25170 being exploited?

There is no known exploitation of CVE-2023-25170 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25170 and fix it if it is affected.

What it is: CVE-2023-25170 is a medium-severity vulnerability in Prestashop Prestashop, published on 13 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-25170 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.0.1
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25170/ (Markdown: https://insights.sbomify.com/CVE-2023-25170/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25170
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25170
- OSV: https://osv.dev/vulnerability/CVE-2023-25170

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25170/
Summaries are generated and may contain mistakes; the official description above is the record.
