CVE-2023-25307 mrpack-install vulnerable to path traversal with dependency

High 7.8 Published Updated

An attacker can exploit a directory traversal vulnerability in the mrpack-install Go library to read or modify arbitrary files on the system.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-25307?

CVE-2023-25307 is a high-severity path traversal vulnerability in n/a, published on 26 Jun 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

nothub mrpack-install <= v0.16.2 is vulnerable to Directory Traversal.

Weakness: CWE-22

Which versions are affected by CVE-2023-25307?

3 open source packages ship an affected version, including github.com/nothub/mrpack-install. It affects 1 product.

PackageAffectedFixed in
github.com/nothub/mrpack-install GoAll versions0.16.3
github.com/nothub/mrpack-install GoAll versions0.16.3
github.com/nothub/mrpack-install GoAll versions0.16.3

Products include Mrpack-Install Project Mrpack-Install.

How do I fix CVE-2023-25307?

Upgrade github.com/nothub/mrpack-install to 0.16.3 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2023-25307 being exploited?

There is no known exploitation of CVE-2023-25307 in the wild and no public exploit code.

Sources

Also known as GHSA-r887-gfxh-m9rr, GO-2023-1543.

Is CVE-2023-25307 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free