# CVE-2023-25307: mrpack-install vulnerable to path traversal with dependency

> An attacker can exploit a directory traversal vulnerability in the mrpack-install Go library to read or modify arbitrary files on the system.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jun 2023
- **Updated:** 4 Dec 2024
- **Also known as:** GHSA-r887-gfxh-m9rr, GO-2023-1543

## What is CVE-2023-25307?

CVE-2023-25307 is a high-severity path traversal vulnerability in n/a, published on 26 Jun 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

nothub mrpack-install <= v0.16.2 is vulnerable to Directory Traversal.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-25307?

3 open source packages ship an affected version, including github.com/nothub/mrpack-install. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nothub/mrpack-install` | Go | All versions | 0.16.3 |
| `github.com/nothub/mrpack-install` | Go | All versions | 0.16.3 |
| `github.com/nothub/mrpack-install` | Go | All versions | 0.16.3 |

Products: Mrpack-Install Project Mrpack-Install.

## How do I fix CVE-2023-25307?

Upgrade github.com/nothub/mrpack-install to 0.16.3 or later.

## Is CVE-2023-25307 being exploited?

There is no known exploitation of CVE-2023-25307 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-25307 and fix it if it is affected.

What it is: CVE-2023-25307 is a high-severity path traversal vulnerability in n/a, published on 26 Jun 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-25307 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nothub/mrpack-install (Go): affected all versions; fixed in 0.16.3
- github.com/nothub/mrpack-install (Go): affected all versions; fixed in 0.16.3
- github.com/nothub/mrpack-install (Go): affected all versions; fixed in 0.16.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-25307/ (Markdown: https://insights.sbomify.com/CVE-2023-25307/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-25307
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-25307
- OSV: https://osv.dev/vulnerability/CVE-2023-25307

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-25307/
Summaries are generated and may contain mistakes; the official description above is the record.
