{"answers":{"affected":"1 open source package ship an affected version, including civicrm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-25440 exists.","fix":"No fix has been published for CVE-2023-25440 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-25440 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-25440 and fix it if it is affected.\n\nWhat it is: CVE-2023-25440 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-25440 exists.\n\nAffected packages and fixed versions:\n- civicrm (Bitnami): affected from 5.59-alpha1.0 up to 5.59-alpha1.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-25440/ (Markdown: https://insights.sbomify.com/CVE-2023-25440/index.md)","id":"CVE-2023-25440","markdown":"https://insights.sbomify.com/CVE-2023-25440/index.md","name":"CVE-2023-25440","record":{"aliases":["BIT-civicrm-2023-25440","DEBIAN-CVE-2023-25440","GHSA-w275-2cjx-pq96","UBUNTU-CVE-2023-25440"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"CiviCRM","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code via stored XSS in CiviCRM contact name fields, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"civicrm","vendor":"civicrm"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Stored Cross Site Scripting (XSS) vulnerability in the add contact function CiviCRM 5.59.alpha1, allows attackers to execute arbitrary code in first/second name field.","ecosystems":["Bitnami"],"exploits":{"exploitdb":1,"first_seen":"2023-05-23","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-05-23","kind":"exploitdb","ref":"51478","stars":null,"title":"CiviCRM 5.59.alpha1 - Stored XSS (Cross-Site Scripting)"}],"tier":"weaponised"},"has_fix":false,"headline":"Cross-site scripting in n/a","id":"CVE-2023-25440","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":1,"n_references":2,"next":{"headline":"WordPress Zeno Font Resizer Plugin \u003c= 1.7.9 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-25442"},"packages":[{"ecosystem":"Bitnami","fixed":[],"introduced":["5.59-alpha1.0"],"last_affected":["5.59-alpha1.0"],"package":"civicrm","purl":"pkg:bitnami/civicrm","source":"BIT-civicrm-2023-25440"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2023-25439"},"products":["n/a"],"published":"2023-05-23","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2018-1999022","kev_date_added":null,"published":"2018-07-23"},{"cvss_score":8.8,"headline":"File upload in n/a","id":"CVE-2020-36388","kev_date_added":null,"published":"2021-06-17"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2013-5957","kev_date_added":null,"published":"2013-11-27"},{"cvss_score":6.5,"headline":"CiviCRM SQL injection vulnerability via Quick Search API","id":"CVE-2013-4662","kev_date_added":null,"published":"2014-01-29"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2025-65187","kev_date_added":null,"published":"2025-12-02"},{"cvss_score":5.8,"headline":"Weak cryptography in n/a","id":"CVE-2011-5239","kev_date_added":null,"published":"2012-11-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-31","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via stored XSS in CiviCRM contact name fields, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2023-25440/"}