{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-25564 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2023-25564 is a medium-severity memory corruption vulnerability in gssapi gss-ntlmssp, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-25564 and fix it if it is affected.\n\nWhat it is: CVE-2023-25564 is a medium-severity memory corruption vulnerability in gssapi gss-ntlmssp, published on 14 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-25564 in the wild and no public exploit code.\n\nAffected product: gssapi gss-ntlmssp. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-25564/ (Markdown: https://insights.sbomify.com/CVE-2023-25564/index.md)","id":"CVE-2023-25564","markdown":"https://insights.sbomify.com/CVE-2023-25564/index.md","name":"CVE-2023-25564","record":{"aliases":["AZL-43441","AZL-45234","DEBIAN-CVE-2023-25564","GHSA-r85x-q5px-9xfq","ROOT-OS-UBUNTU-2204-CVE-2023-25564","UBUNTU-CVE-2023-25564"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"GSS-NTLMSSP library","requires_auth":"none","summary":"An attacker can trigger memory corruption via crafted UTF16 strings in GSS-NTLMSSP, potentially causing denial of service or arbitrary code execution.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"gss-ntlmssp","vendor":"gss-ntlmssp_project"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, memory corruption can be triggered when decoding UTF16 strings. The variable `outlen` was not initialized and could cause writing a zero to an arbitrary place in memory if `ntlm_str_convert()` were to fail, which would leave `outlen` uninitialized. This can lead to a denial of service if the write hits unmapped memory or randomly corrupts a byte in the application memory space. This vulnerability can trigger an out-of-bounds write, leading to memory corruption. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This issue is fixed in version 1.2.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GSS-NTLMSSP vulnerable to memory corruption when decoding UTF16 strings","id":"CVE-2023-25564","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2023"},"n_packages":0,"n_references":3,"next":{"headline":"GSS-NTLMSSP vulnerable to incorrect free when decoding target information","id":"CVE-2023-25565"},"packages":[],"prev":{"headline":"GSS-NTLMSSP vulnerable to multiple out-of-bounds reads when decoding NTLM fields","id":"CVE-2023-25563"},"products":["gss-ntlmssp"],"published":"2023-02-14","related":[{"cvss_score":7.5,"headline":"GSS-NTLMSSP vulnerable to incorrect free when decoding target information","id":"CVE-2023-25565","kev_date_added":null,"published":"2023-02-14"},{"cvss_score":7.5,"headline":"GSS-NTLMSSP vulnerable to memory leak when parsing usernames","id":"CVE-2023-25566","kev_date_added":null,"published":"2023-02-14"},{"cvss_score":7.5,"headline":"GSS-NTLMSSP vulnerable to out-of-bounds read when decoding target information","id":"CVE-2023-25567","kev_date_added":null,"published":"2023-02-14"},{"cvss_score":5.9,"headline":"GSS-NTLMSSP vulnerable to multiple out-of-bounds reads when decoding NTLM fields","id":"CVE-2023-25563","kev_date_added":null,"published":"2023-02-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["gssapi"]},"summary":"An attacker can trigger memory corruption via crafted UTF16 strings in GSS-NTLMSSP, potentially causing denial of service or arbitrary code execution.","url":"https://insights.sbomify.com/CVE-2023-25564/"}